TE110P Wildcard Does Not Work With Ubuntu 12.04 Server

Home » Asterisk Users » TE110P Wildcard Does Not Work With Ubuntu 12.04 Server
Asterisk Users 5 Comments

I am trying to setup TE110P wildcard on a PBX running ubuntu 12.04 server edition. I followed the procedure from http://docs.digium.com/misc/ADL_quickstart.pdf step by step.

During the process of installing “dahdi-linux-complete”

I got following warnings:

root@ubuntu:/usr/local/src/dahdi-linux-complete-2.6.1+2.6.1# make

perl: warning: Setting locale failed. perl: warning: Please check that your locale settings:
LANGUAGE = “en_US:en”, LC_ALL = (unset), LC_CTYPE = “UTF-8”, LANG = “en_US.UTF-8”
are supported and installed on your system. perl: warning: Falling back to the standard locale (“C”).

Frist of, I am wondering if this error matters?

Second question, after installation process complete, and reboot the machine

I got the following error, when machine boot up:

Loading DAHDI hardware modules:
wcte11xp: error

I think the TE110P card is no properly loaded.

I try to confirm my thought by using root@ubuntu:~# dahdi_tool

There is no interface listed on the table.

I am wondering if anyone got idea about this issue. Thanks.

longst

5 thoughts on - TE110P Wildcard Does Not Work With Ubuntu 12.04 Server

  • I think you can safely ignore these warnings. You might need to make sure those locales are properly setup on your server to get rid of the warnings. See http://ubuntuforums.org/showthread.php?t46581

    You will want to runt he dmesg command after trying to load the driver to see if there are any errors listed.

    Run these commands as root and send the output:

    # dmesg -c > /dev/null
    # /etc/init.d/dahdi stop
    # modprobe wte11xp
    # dmesg

    dahdi_tool will not be able to see the interface since the driver failed to load in the previous step.

  • Op 22-08-12 12:09, Shitian Long schreef:
    Please try the command “lspci” and see if the card is mentioned in the results. Regards.

    Michel.

  • Michel Verbraak verbraak.org> writes:

    from http://docs.digium.com/misc/ADL_quickstart.pdf step

    Having the same problems:

    /# dmesg -c > /dev/null
    /# /etc/init.d/dahdi stop Unloading DAHDI hardware modules: done
    /# modprobe wte11xp FATAL: Module wte11xp not found.
    /# dmesg
    [ 2775.316252] dahdi: Telephony Interface Unloaded

    /# lspci | grep Dig
    /#

    however:

    # make config install -D dahdi.init /etc/init.d/dahdi
    /usr/sbin/update-rc.d dahdi defaults 15 30
    System start/stop links for /etc/init.d/dahdi already exist. DAHDI has been configured.

    List of detected DAHDI devices:

    pci:0000:03:02.0 wcte11xp- e159:0001 Digium Wildcard TE110P T1/E1 Board

    run ‘dahdi_genconf modules’ to load support for only the DAHDI hardware installed in this system. By default support for all DAHDI hardware is loaded at DAHDI start.

    any ideas? doesnt look like my system recognized the card at all. no lights on the card. card was working perfectly. i simply moved it from one box (gentoo)
    to another (ubuntu 12.04)

  • Hi,

    I do not think this error matters. You probably should still make sure your locale is set properly.

    There should be some output in dmesg that indicates what the problem is when you get an error here.

    The above is a differnt error than what Shitian reported. It doesn’t look like the driver was installed properly for the current kernel.

    Best guess based on what you said that the driver really isn’t installed for the current kernel.

    Cheers, Shaun