Fax Problem on direct FXO port

Home » Asterisk Users » Fax Problem on direct FXO port
Asterisk Users 4 Comments

Sebastian,

Seeing as this an issue related to faxing using the SpanDSP library;
if you do not get an answer leading to a solution here, then you may try
asking on the SpanDSP mailing list
http://lists.soft-switch.org/mailman/listinfo

It’s likely that the Asterisk users, specifically using SpanDSP, may be
on that list.

Thanks,

Rusty Newton
Open Source Community Support Manager
Digium, Inc | www.digium.com | www.asterisk.org

On 5/16/2012 12:44 PM, Sebastian Gutierrez wrote:
> Hi,
>
>
> I´m with asterisk 1.6.2.20
> DAHDI Version: 2.5.0.2 Echo Canceller: HWEC, MG2
> SpanDSP: spandsp-0.0.6pre20.tgz
> http://www.soft-switch.org/downloads/spandsp/spandsp-0.0.6pre20.tgz
>
> FXO lines.
>
> Sending faxes works ok.
>
> but receiving gives me error:
>
> here is the debug:
>
> http://pastebin.com/qfFeXWQW
>
>
> any idea??
>
>
> Thanks!
>
>
>
> —
> _____________________________________________________________________
> — Bandwidth and Colocation Provided by http://www.api-digital.com
> New to Asterisk? Join us for a live introductory webinar every Thurs:
> http://www.asterisk.org/hello
>
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
> http://lists.digium.com/mailman/listinfo/asterisk-users

4 thoughts on - Fax Problem on direct FXO port

  • Rusty,

    thanks for the reply, the issue seems a spandsp issue, I changed to digium free asterisk fax and works much better, has still some issues that not all faxes pass ok, but does the work.

    thanks!

  • Hi Sebastian,

    “has still some issues that not all faxes pass ok, but does the work” ==
    still badly broken

    Your log doesn’t seem to show a spandsp error. It looks more like a bad
    signal. Did you change anything else when you installed FFA? Usually
    people move the other way to improve their results.

    Steve

  • Hi Steve,

    Thanks for the reply, I didn’t change anything else, just changed spandsp version to de FFA, I use the spandsp version with more success in other places, but in this particular case, sending faxes works ok with both versions but with spandsp I couldn’t receive any fax, with FFA I may get 70% of faxes ok.