* You are viewing the archive for May 9th, 2012

Digium IP Phones

Hello,

Im looking to buy a digium phone D70 unit just for testing on lab; to
really understand the phone and features.

I cant find any website with opinions; any here? Are they really valuable
to the price? (D70 quite expensive)

Does the SDK for building apps is usable? Can you build powerfull apps?
Examples?

Many thanks

Why do I get call twice in one go?

I understand why do I get call twice to my mobile when I execute the
following AMI command sets:

ACTION: Originate
Channel: Local/800@test
Timeout: 60000
Priority: 1

and my dialplan look like this:

[test]
exten => 800,1,DIAL(SIP/447xxxxxx@voip);
exten => 800,n,Hangup()

How to prevent getting called twice in one go when I execute this AMI
command?

Thanks…

what to use for a B410P

Hi,

I’m experiencing difficulties to get a B410P running with Asterisk
10.3.1 and DAHDI 2.6.1.
Am I supposed to use DAHDI for this card and ISDN BRI for my country
(Belgium)?

thx,

BC

British Telecom ISDN BRI line issues

Should I understand that no Asterisk user has issues with ISDN “system
access” configuration from UK? or maybe no one is using Asterisk In UK :) ?

On Tue, May 8, 2012 at 12:46 PM, khalid touati wrote:

> Hi All,
> I am posting this thread with the hope that someone in UK (or elsewhere)
> had a similar issue:
> Our issue is simple, we cannnot use our ISDN line, when watching asterisk
> console it gives a bunch of ISDN errors where the following is probably the
> most relevant:
>
> Span: 4 TEI=0 MDL-ERROR (J): N(R) error in state 7(Multi-frame established)
>
> We are using asterisk 1.8.12.0 with dahdi 2.6.0, on CentOS 6.2. I can post
> configuration and/or further information if needed.
>
> –
> Khalid Touati
> Network Administrator
> CCNA
>
>
>

No compatible codecs, not accepting this offer! – after upgrading to 1.8.11

Hi,

I’ve upgraded my asterisk 1.4 to the version 1.8.11. After making some
adjustments to the configuration files to port it to the new version, calls
between registered phones in asterisk, work fine, but inbound calls coming
from the SIP trunk I have with a telco to asterisk, don’t work anymore. I
don’t know why!…

This is the SDP portion that comes in the INVITE messages of calls through
that trunk (let’s say, whose endpoint has the IP x.x.x.x, purposely
omitted). Nothing seems to be wrong with that to me:
v=0
o=CSM 0 1 IN IP4 x.x.x.x
s=Acme
c=IN IP4 x.x.x.x
t=0 0
m=audio 22152 RTP/AVP 8 0 18 4 101
a=rtpmap:101 telephone-event/8000

And here’s the debugging:
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:5092 do_setnat: Setting NAT on RTP
to Off
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:8891 process_sdp: Processing
session-level SDP v=0… UNSUPPORTED.
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:8891 process_sdp: Processing
session-level SDP o=CSM 0 1 IN IP4 x.x.x.x… UNSUPPORTED.
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:8891 process_sdp: Processing
session-level SDP s=Acme… UNSUPPORTED.
[May 8 17:45:30] DEBUG[6444]: netsock2.c:134 ast_sockaddr_split_hostport:
Splitting ‘x.x.x.x’ into…
[May 8 17:45:30] DEBUG[6444]: netsock2.c:188 ast_sockaddr_split_hostport:
…host ‘x.x.x.x’ and port ”.
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:8891 process_sdp: Processing
session-level SDP c=IN IP4 x.x.x.x… OK.
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:8891 process_sdp: Processing
session-level SDP t=0 0… UNSUPPORTED.
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:537
ast_rtp_codecs_payloads_set_m_type: Setting payload 8 based on m type on
0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:537
ast_rtp_codecs_payloads_set_m_type: Setting payload 0 based on m type on
0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:537
ast_rtp_codecs_payloads_set_m_type: Setting payload 18 based on m type on
0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:537
ast_rtp_codecs_payloads_set_m_type: Setting payload 4 based on m type on
0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:537
ast_rtp_codecs_payloads_set_m_type: Setting payload 101 based on m type on
0x416e25b0
[May 8 17:45:30] DEBUG[6444]: chan_sip.c:9110 process_sdp: Processing
media-level (audio) SDP a=rtpmap:101 telephone-event/8000… OK.
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:640
ast_rtp_codecs_payload_formats: Incorporating payload 0 on 0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:640
ast_rtp_codecs_payload_formats: Incorporating payload 4 on 0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:640
ast_rtp_codecs_payload_formats: Incorporating payload 8 on 0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:640
ast_rtp_codecs_payload_formats: Incorporating payload 18 on 0x416e25b0
[May 8 17:45:30] DEBUG[6444]: rtp_engine.c:640
ast_rtp_codecs_payload_formats: Incorporating payload 101 on 0x416e25b0
[May 8 17:45:30] NOTICE[6444]: chan_sip.c:9188 process_sdp: No compatible
codecs, not accepting this offer!

Any help?

Thanks,
Ricardo.