chan_dahdi with asterisk 1.4 and new Linux versions

Home » Asterisk Users » chan_dahdi with asterisk 1.4 and new Linux versions
Asterisk Users 3 Comments

Hi All;

First of all, I am trying to install vicidial and actually vicidial requires asterisk 1.4 and can not work with asterisk 1.8, in addition there is a special version of asterisk 1.4 that is required for vicidial which is asterisk-1.4.39.1-vici.

The problem that it look like there is a problem with that asterisk 1.4 is not able to buld chan_dahdi if the linux version is new (like fedora core 16), while asterisk 1.8 can work fine with new linux versions.

What is happening with me that when I used fedora core 16, I compiled and installed dahdi 2.6 and then compiled and installed asterisk 1.4 and it did not create chan_dahdi. I tried to select it by running make menuselect and I discover that it is not possible !! By the way: this problem is not existed with old linux versions ..

How I can resolve this problem? How I can let asterisk 1.4 ables to build chan_dahdi with new fedora (or ubuntu) versions?

Again, I do not see this problem when I am using asterisk 1.8 with new linux versions.

Appreciate the kindly help.
Regards
Bilal

3 thoughts on - chan_dahdi with asterisk 1.4 and new Linux versions

  • Dear Tzafrir;

    For sure I re run ./configure

    Actually, I formatted the machine and reinstalled .. also I removed the asterisk 1.4 and extracted again and I ran ./configure, make and make install. All of these I tried !

    As long the Linux OS is new, then it is not possible to get chan_dahdi. And if the OS is new, then we can not compile old DAHDI (versions before 2.4 and maybe 2.4 it self can not be compiled if the OS is new).

    I tried Fedora and Ubuntu.

    But with asterisk 1.8, things are running well.

    Any help?
    Regards
    Bilal

  • What is chan_dahdi missing?

    ./menuselect/contrib/dummy-select -c
    ./menuselect/contrib/dummy-select -m chan_dahdi -v