Compile error 1.8.8.1

Home » Asterisk Users » Compile error 1.8.8.1
Asterisk Users 2 Comments

Hi,

While compiling 1.8.8.1, I met the following error:

[AR] hash/hash.o hash/hash_bigkey.o hash/hash_buf.o hash/hash_func.o
hash/hash_log2.o hash/hash_page.o hash/ndbm.o btree/bt_close.o
btree/bt_conv.o btree/bt_debug.o btree/bt_delete.o btree/bt_get.o
btree/bt_open.o btree/bt_overflow.o btree/bt_page.o btree/bt_put.o
btree/bt_search.o btree/bt_seq.o btree/bt_split.o btree/bt_utils.o db/db.o
mpool/mpool.o recno/rec_close.o recno/rec_delete.o recno/rec_get.o
recno/rec_open.o recno/rec_put.o recno/rec_search.o recno/rec_seq.o
recno/rec_utils.o -> libdb1.a
[LD] abstract_jb.o acl.o alaw.o aoc.o app.o ast_expr2.o ast_expr2f.o
asterisk.o astfd.o astmm.o astobj2.o audiohook.o autochan.o autoservice.o
bridging.o callerid.o ccss.o cdr.o cel.o channel.o chanvars.o cli.o
config.o data.o datastore.o db.o devicestate.o dial.o dns.o dnsmgr.o dsp.o
enum.o event.o features.o file.o fixedjitterbuf.o frame.o framehook.o
fskmodem.o global_datastores.o hashtab.o heap.o http.o image.o
indications.o io.o jitterbuf.o loader.o lock.o logger.o manager.o md5.o
netsock.o netsock2.o pbx.o plc.o poll.o privacy.o rtp_engine.o say.o
sched.o security_events.o sha1.o slinfactory.o srv.o ssl.o
stdtime/localtime.o strcompat.o strings.o stun.o syslog.o taskprocessor.o
tcptls.o tdd.o term.o test.o threadstorage.o timing.o translate.o udptl.o
ulaw.o utils.o version.o xml.o xmldoc.o editline/libedit.a db1-ast/libdb1.a
-> asterisk
pbx.o: In function `ast_str_substitute_variables_full’:
/usr/src/asterisk/asterisk-1.8.8.1/main/pbx.c:3786: undefined reference to
`ast_str_expr’
collect2: ld returned 1 exit status
make[1]: *** [asterisk] Error 1
make: *** [main] Error 2

Without making any further changes, compiling 1.8.8.0 worked without any
errors. It seems, this is stemming from compiling:

[CC] xmldoc.c -> xmldoc.o

I ran with “–disable-xmldoc” flag while running “./configure”, and this
time also compilation failed with the same error. I’ve reverted back to
using 1.8.8.0.

Any suggestions on why this is happening, or what am I doing wrong?

Regards
HASSAN

2 thoughts on - Compile error 1.8.8.1