Cisco AS5300 and Digium g729A codec

Home » Asterisk Users » Cisco AS5300 and Digium g729A codec
Asterisk Users 4 Comments

Hi,

We have a problem connecting to a Cisco AS5300 trunk.

We set the sip peer to allow only g729. The call attempt is able to
connect, but when answered, no audio is heard or transmitted.

Our asterisk version is 1.6.2.14 . Codec is licensed, bought from Digium.

We do not have this problem on our other providers using asterisk and other
non-cisco systems.
Anyone else having this same problem?

4 thoughts on - Cisco AS5300 and Digium g729A codec

  • You are hereby encouraged to post your AS5300 IOS config, sip.conf peer declaration, and packet capture. Those three things would aid greatly in diagnosis, especially the capture.

  • Hi Alex, here’s the config and the sip debug output.

    Guide:
    xxx.xxx.xxx.xxx – the provider’s cisco as5300 trunk ip add
    yyy.yy.yy.yy – our asterisk 1.6.2.14 server

    sip config:

    type=peer
    disallow=all
    allow=g729
    host=xxx.xxx.xxx.xxx
    fromdomain=xxx.xxx.xxx.xxx
    dtmfmode=rfc2833
    nat=no
    canreinvite=yes
    context=from-trunk-sip-iaccess

    sip debug:
    v=0
    o=root 249777024 249777024 IN IP4 yyy.yy.yy.yy
    s=Asterisk PBX 1.6.2.14
    c=IN IP4 yyy.yy.yy.yy
    t=0 0
    m=audio 13702 RTP/AVP 0 8 3 18 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:8 PCMA/8000
    a=rtpmap:3 GSM/8000
    a=rtpmap:18 G729/8000
    a=fmtp:18 annexb=no
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    a=sendrecv

  • Here’s the cisco AS5300 settings from our provider

    codec preference 1 g729r8
    codec preference 2 g729br8
    codec preference 3 g723r53
    codec preference 4 g723r63
    codec preference 5 g723ar53
    codec preference 6 g723ar63