Sporadic yellow alarms in dahdi_tool output

Home » Asterisk Users » Sporadic yellow alarms in dahdi_tool output
Asterisk Users 1 Comment

Hi all,

We have a telephony server in India which runs CentOS release 5.7 (Final)
version with four-span Digium Card, one of which has an E1 PRI line
terminating on the server.
$ dahdi_hardware
pci:0000:07:08.0 wct4xxp+ d161:1420 Wildcard TE420 (5th Gen)

Recently we’ve been observing the status of Span 1 as observed from
dahdi_tool output flaps between yellow and green. This happens a couple of
few a day.
While the span state is yellow, I observed that the
modules dahdi_echocan_mg2 and wct4xxp are not loaded.

After running sudo modprobe wct4xxp; sudo modprobe dahdi_echocan_mg2, the
span state changes to green.
The dahdi documentation has the following to say on yellow alarms:

(RAI — Remote Alarm Indication)

Your T1/E1 port will go into yellow alarm when it receives a signal from
the remote switch that the port on that remote switch is in red alarm. This
essentially means that the remote switch is not able to maintain sync with
you, or is not receiving your transmission.

As a newbie to asterisk, pointers will be very helpful. Here are some more
details on the installed versions of various packages/modules.

1. Linux Kernel Version : $ uname -a
Linux 022.exotel.in 2.6.18-274.3.1.el5 #1 SMP Tue Sep 6 20:13:52 EDT 2011
x86_64 x86_64 x86_64 GNU/Linux
2. Dahdi verison: dahdi-linux-complete-2.5.0.1+2.5.0.1
3. Asterisk verison: asterisk-1.8.6.0
4. libpri version: libpri-1.4.12

Is this a configuration issue, package version issue or an operator issue?
I’ll be glad to share the necessary dahdi configuration files if needed.

Thanks in advance.

One thought on - Sporadic yellow alarms in dahdi_tool output

  • hi:you have to add that in system.conf, check the file, by default is is OSLEC, you can change to MG2.please refer this link fore the system.conf:http://www.voip-info.org/wiki/view/system.conf

    Best regards,
    James.zhu
    Doing asterisk/PRI/ss7/dahdi, linux, asterisk cards, gateway(fxs/fxo/pri< ->SIP).
    website: http://www.voipviews.com

    Thanks for the response James. I shall talk with the provider.If the problem resides with the remote side, how does loading dahdi_echocan_mg2 and wct4xxp modules fix the issue, atleast temporarily?