* You are viewing the archive for June 4th, 2012

IMAP integration with MS Exchange 2010

Greetings,

Has anybody here successfully integrated IMAP voicemail with Exchange 2010? If so – could you point me in the right direction to configure this properly?

I’m running Asterisk 1.8.11-cert2.

My voicemail.conf:

[general]
format=wav49
imapserver=mail.domain.com
authuser=asterisk_master
authpassword=asterisk_master_password
expungeonhangup=no
pollmailboxes=yes
pollfreq=30
imapgreetings=no
userscontext=customercontext
searchcontexts=yes

(*I have tried adding imapport=993 and imapflags=ssl, but just adds a ‘security problem’ error message to the logfiles).

my voicemail users are in Realtime, and I have a column populated and set for imapuser (you can see in the log errors below that we are successfully getting imapuser from the database and inserting it in the connect string).

Here’s what happens when I try to leave a voicemail message:

[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Can’t use Kerberos: invalid /authuser
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2852 mm_log: IMAP Error: Can not authenticate to IMAP server: AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: [CLOSED] IMAP connection broken (server response)
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2598 init_mailstream: Can’t connect to imap server {mail.domain.com:143/imap/authuser=asterisk_master/notls/user=username}INBOX
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2122 __messagecount: Houston we have a problem – IMAP mailstream is NULL
[2012-06-04 15:34:49] NOTICE[32327]: app_voicemail_imapstorage.c:6159 leave_voicemail: Can not leave voicemail, unable to count messages

Am I just headed down a dead end road?

Regards,

Ric Marques

Asterisk 10.5.0 Now Available

The Asterisk Development Team has announced the release of Asterisk 10.5.0. This release is available for immediate download at http://downloads.asterisk.org/pub/telephony/asterisk

The release of Asterisk 10.5.0 resolves several issues reported by the community and would have not been possible without your participation. Thank you!

The following is a sample of the issues resolved in this release:

  • Turn off warning message when bind address is set to any. (Closes issue ASTERISK-19456. Reported by Michael L. Young)
  • Prevent overflow in calculation in ast_tvdiff_ms on 32-bit  machines (Closes issue ASTERISK-19727. Reported by Ben Klang)
  • Make DAHDISendCallreroutingFacility wait 5 seconds for a reply before disconnecting the call. (Closes issue ASTERISK-19708. Reported by mehdi Shirazi)
  • Fix recalled party B feature flags for a failed DTMF atxfer. (Closes issue ASTERISK-19383. Reported by lgfsantos)
  • Fix DTMF atxfer running h exten after the wrong bridge ends. (Closes issue ASTERISK-19717. Reported by Mario)

For a full list of changes in this release, please see the ChangeLog:

http://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-10.5.0

Thank you for your continued support of Asterisk!

Asterisk 1.8.13.0 Now Available

The Asterisk Development Team has announced the release of Asterisk 1.8.13.0. This release is available for immediate download at http://downloads.asterisk.org/pub/telephony/asterisk

The release of Asterisk 1.8.13.0 resolves several issues reported by the community and would have not been possible without your participation. Thank you!

The following is a sample of the issues resolved in this release:

* — Turn off warning message when bind address is set to any. (Closes issue ASTERISK-19456. Reported by Michael L. Young)
* — Prevent overflow in calculation in ast_tvdiff_ms on 32-bit machines (Closes issue ASTERISK-19727. Reported by Ben Klang)
* — Make DAHDISendCallreroutingFacility wait 5 seconds for a reply before disconnecting the call. (Closes issue ASTERISK-19708. Reported by mehdi Shirazi)
* — Fix recalled party B feature flags for a failed DTMF atxfer. (Closes issue ASTERISK-19383. Reported by lgfsantos)
* — Fix DTMF atxfer running h exten after the wrong bridge ends.

(Closes issue ASTERISK-19717. Reported by Mario)

For a full list of changes in this release, please see the ChangeLog:

http://downloads.asterisk.org/pub/telephony/asterisk/ChangeLog-1.8.13.0

Thank you for your continued support of Asterisk!

Sangoma D100 Transcoder Asterisk 1.6

I have installed and configures this card in asterisk 1.6. When trying to
load the module codec_sangoma.so I see the following in the asterisk log.

[2012-06-04 15:50:31] WARNING[18168] loader.c: Error loading module
‘codec_sangoma.so’: /usr/lib/asterisk/modules/codec_sangoma.so: undefined
symbol: ast_config_load
[2012-06-04 15:50:31] WARNING[18168] loader.c: Module ‘codec_sangoma.so’
could not be loaded.

Has anyone had a similar issue with this card or have any idea what the
undefined symbol: ast_config_load might mean to figure out what direction
to head for further debugging?

Messaging capable app_sms

Hi,

has someone done a patch for app_sms so it is capable of sending the SMS
down the messaging-infrastructure in asterisk-10?

Regards,

Jay