No progress tones on transferred call

Report
Question

Asterisk 1.4
We are experiencing an issue on transfers where no progress tones are heard
by the caller:
1. Call from 1593 (SPA525G 0026998D2FFFF) to 1595 (SPA922 000B820AFFFFF).
1595 answers
2. From 1593 initiate transfer to 1597 (SPA508G 1CDF0F4AFFFF). 1595 hears
MoH.
3. 1597 starts ringing and 1593 presses transfer again. MoH stops but 1595
hears no ringing
When xfer is pressed and the extension is dialled:
U 203.89.001.001:5060 -> 121.98.001.001:1034
INVITE sip:1CDF0F4AFFFF@192.168.1.72:5060 SIP/2.0..Via: SIP/2.0/UDP
203.89.001.001:5060;branch=z9hG4bK5286810e;rport..From: "C Allerid"
;tag=as72616c50..To:
..Contact:
..Call-ID:

Asterisk Users 3.2 years ago 0 Answers

Error about codecs AMR-NB.

Report
Question

 Hi.
 Anyone know how to fix this problem below.
 I'm add codecs AMR-NB and AMR-WB and I get error in AMR-NB about this "Found unknown media description format AMR for ID", a search about this on google and I can't find any solution about this. Thanks in advanced and best regards.              Julio Lemos
< ------------->--- (8 headers 0 lines) ---
< --- SIP read from UDP:192.168.3.227:45327 --->INVITE sip:5432@192.168.3.148 SIP/2.0Via: SIP/2.0/UDP 192.168.3.227:45327;rport;branch=z9hG4bKPjQv3ZDrKzwWFMfOO4eFG0AECvwqEerQ9AMax-Forwards: 70From: "5505" ;tag=H24FA8xsH7K9DpuES9CbWgGkvbYSfF8qTo: Contact: "5505" Call-ID: WyL8a33LsNOaQjw2WbVUN7qj0R4hyEMOCSeq: 13600 INVITEAllow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, SUBSCRIBE,…

Asterisk Users 3.2 years ago 0 Answers

Can't make Asterisk send authentication to remote peer on INVITE

Report
Question

This is a really simple problem that I just can't get to work. There
are two Asterisk servers with the following sip user and peer. When a
call is attempted, Asterisk is not sending authentication details in
response to the 401. Note, if the secret is blank on 172.16.0.2 test,
the INVITE succeeds. on 172.16.0.2: [test]
type=friend
secret=abcde
host=dynamic
context=demo on 172.16.0.1 : [natty]
type=peer
host=172.16.0.2
fromuser=test
secret=abcde originate SIP/natty/1234568 extension 200
== Using SIP RTP CoS mark 5
Audio is at 172.16.0.1 port 19486

Asterisk Users 3.3 years ago 2 Answers

SIP trunk call initiated as Anonymous@anonymous.invalid

Report
Question

I have a Grandstream HT-502 device connected to my Asterisk PBX. It is
configured not to place anonymous calls, and from my mostly layman
reading of the invitation that the device sends, it should not be
anonymous. However, the Asterisk PBX sends an anonymous invitation to
our SIP trunk provider. Can anyone explain why? The two INVITE packets follow. The devices sends the following INVITE: INVITE sip:2223334444@pbx.xxxxx.com SIP/2.0
Via: SIP/2.0/UDP 192.168.9.197:46538;branch=z9hG4bK526774101;rport
From: "222333555" ;tag=2072922124
To:
Call-ID: 1082640776-46538-3@BJC.BGI.J.BJH
CSeq: 21 INVITE
Contact: "222333555"
Authorization:…

Asterisk Users 3.6 years ago 0 Answers

No rtpmap codec info in 200 OK

Report
Question

Hi, My VSP uses Asterisk to which I'm connected with an ATA. When I receive an inbound call the invite includes the following... v=0
o=root 32218 32218 IN IP4 202.52.129.50
s=session
c=IN IP4 202.52.129.50
t=0 0
m=audio 16864 RTP/AVP 18 101
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off – - – -
a=ptime:20
a=sendrecv My ATA's 200 OK reply after call setup has the following... v=0
o=CMI-SIPUA 13369 0 IN IP4 211.30.XXX.XXX
s=SIP CALL
c=IN IP4 211.30.XXX.XXX
t=0 0
m=audio 20216…

Asterisk Users 3.7 years ago 7 Answers

a=sendonly Music On Hold ignored

Report
Question

Hello all, I have a problem of "Music on Hold" on AsteriskNow system, based on Asterisk
1.6.2.19 with FreePBX 2.8.1.4 On another system, when we press the HOLD button on the phone, the phone
sends an INVITE with a=sendonly in the SDP, and we get an OK and the system
recognizes the a=sendonly request and starts the music on hold, as you can
see from the following log: < --- SIP read from UDP:10.0.0.2:5060 --->
INVITE sip:21@10.0.0.10 SIP/2.0
Via: SIP/2.0/UDP 10.0.0.2:5060;rport;branch=z9hG4bK337477455
From: "1001" ;tag=446928907
To: ;tag=as479a82ac
Call-ID: 65159842@10.0.0.2

Asterisk Users 4.1 years ago 6 Answers

Problems Extension with a Call In on Asterisk 1.6

Report
Question

Hi I request your help because i don't have actually a solution at my problems.
I have a Asterisk Server in 1.6
Connected at a SIP Provider
This provider supply me 2 numbers:
003318364xxxx (official number)
081169xxxx (Nddi Number) When i receive a call on the 081169xxxx, he don't use
the extension. He use the 003318364xxxx extension. SIP Debug: < --- SIP read from UDP://91.121.xxx.xxx:5060 --->
INVITE sip:003318364xxxx@78.41.xxx.xxx:5060;transport=udp SIP/2.0
Allow: UPDATE,REFER,INFO
Call-ID:
04459-NK-5fa6f8a0-18641fd41@sip.myoperator.net
Contact:
Content-Type: application/sdp
CSeq: 1602837515 INVITE
From: "033426aaaaaa"

Asterisk Users 4.4 years ago 3 Answers

Unable to make outgoing calls with Internode

Report
Question

Surely there must be someone here who can help me with this problem. I have spent weeks trying to get this damned service to work with no
luck. I have incoming calls working, but no outgoing. If get outgoing
working then incoming don't work. I have sent this problem to this list a couple of times with little or
no response, and I _really_ need some help to sort it out. I have an asterisk 1.8 server running on FreeBSD 8.1, and another
FreeBSD 8.1 running as a firewall/gateway with PF. I have a nodephone service…

Asterisk Users 4.5 years ago 3 Answers

Asterisk SIP with no RTP audio port (was Internode weirdness)

Report
Question

On 01/22/11 22:04, Da Rock wrote:
> On 01/22/11 20:00, Da Rock wrote:
>> On 01/21/11 20:28, Da Rock wrote:
>>> On 01/21/11 03:19, Tom Rymes wrote:
>>>> On 01/19/2011 10:34 PM, Da Rock wrote:
>>>>
>>>>> WARNING[988]: chan_sip.c:19069 handle_response_invite: Re-invite to
>>>>> non-existing call leg on other UA. SIP dialog
>>>>> '481cf0543743e6bb7006991d409ed3bc@150.101.178.33:5060'. Giving up.
>>>>
>>>> Have you tried disallowing re-invites?
>>> Sorry for the delay, but I've tried both yes and no- one of the
>>> first things I tried, but I get your reasoning.

Asterisk Users 4.6 years ago 1 Answer

slow response to INVITE

Report
Question

Hi All, I;m using asterisk 1.4 with FreePBX and a Grandstream 4108. I am
noticing a delay calling in and out via the FXO, but calls to local
extension are ok. What i noticed when i used ngrep is that, it sends
invite but got no response from the server, send another invite but got
no response again, then again until it finally gets it. but if you will
notice on the 2nd ngrep, the asterisk replied to all the INVITE's it
received before it says Ringing. Really need help on this badly, anyone

Asterisk Users 4.6 years ago 0 Answers