* You are viewing Posts Tagged ‘master password’

IMAP integration with MS Exchange 2010

Greetings,

Has anybody here successfully integrated IMAP voicemail with Exchange 2010? If so – could you point me in the right direction to configure this properly?

I’m running Asterisk 1.8.11-cert2.

My voicemail.conf:

[general]
format=wav49
imapserver=mail.domain.com
authuser=asterisk_master
authpassword=asterisk_master_password
expungeonhangup=no
pollmailboxes=yes
pollfreq=30
imapgreetings=no
userscontext=customercontext
searchcontexts=yes

(*I have tried adding imapport=993 and imapflags=ssl, but just adds a ‘security problem’ error message to the logfiles).

my voicemail users are in Realtime, and I have a column populated and set for imapuser (you can see in the log errors below that we are successfully getting imapuser from the database and inserting it in the connect string).

Here’s what happens when I try to leave a voicemail message:

[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Can’t use Kerberos: invalid /authuser
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2852 mm_log: IMAP Error: Can not authenticate to IMAP server: AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: [CLOSED] IMAP connection broken (server response)
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2598 init_mailstream: Can’t connect to imap server {mail.domain.com:143/imap/authuser=asterisk_master/notls/user=username}INBOX
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2122 __messagecount: Houston we have a problem – IMAP mailstream is NULL
[2012-06-04 15:34:49] NOTICE[32327]: app_voicemail_imapstorage.c:6159 leave_voicemail: Can not leave voicemail, unable to count messages

Am I just headed down a dead end road?

Regards,

Ric Marques