* You are viewing Posts Tagged ‘error’

Reliable method for FoIP

Hi,

I’m looking for a method to setup FoIP i.e. using T.38 protocol with no
PSTN lines.

I tested T.38 feature for Asterisk but the problem I’m getting is unable to
send more than 2 pages but getting timeout error.

Past couple of years I also configured and tested hylafax + iaxmodem for
T.30 faxing but I would like to know whether it also supports T.38
protocol or not?

Is there any other reliable method available for FoIP? If it is, please
share your views.

IMAP integration with MS Exchange 2010

Greetings,

Has anybody here successfully integrated IMAP voicemail with Exchange 2010? If so – could you point me in the right direction to configure this properly?

I’m running Asterisk 1.8.11-cert2.

My voicemail.conf:

[general]
format=wav49
imapserver=mail.domain.com
authuser=asterisk_master
authpassword=asterisk_master_password
expungeonhangup=no
pollmailboxes=yes
pollfreq=30
imapgreetings=no
userscontext=customercontext
searchcontexts=yes

(*I have tried adding imapport=993 and imapflags=ssl, but just adds a ‘security problem’ error message to the logfiles).

my voicemail users are in Realtime, and I have a column populated and set for imapuser (you can see in the log errors below that we are successfully getting imapuser from the database and inserting it in the connect string).

Here’s what happens when I try to leave a voicemail message:

[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Can’t use Kerberos: invalid /authuser
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:48] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: Retrying PLAIN authentication after AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2852 mm_log: IMAP Error: Can not authenticate to IMAP server: AUTHENTICATE failed.
[2012-06-04 15:34:49] WARNING[32327]: app_voicemail_imapstorage.c:2849 mm_log: IMAP Warning: [CLOSED] IMAP connection broken (server response)
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2598 init_mailstream: Can’t connect to imap server {mail.domain.com:143/imap/authuser=asterisk_master/notls/user=username}INBOX
[2012-06-04 15:34:49] ERROR[32327]: app_voicemail_imapstorage.c:2122 __messagecount: Houston we have a problem – IMAP mailstream is NULL
[2012-06-04 15:34:49] NOTICE[32327]: app_voicemail_imapstorage.c:6159 leave_voicemail: Can not leave voicemail, unable to count messages

Am I just headed down a dead end road?

Regards,

Ric Marques

Call Record File and Play

Hello,

I am trying to achieve call record file and play the file to the user using
phpagi script.

I am using the following code

$rand=”/var/sounds/145712900″;

$agi->record_file($rand, “gsm”, “0123456789*#”, -1, 0, true, 0);

also tried

$agi->record_file($rand, “wav”, “0123456789*#”, -1, 0, true, 0);

the file is created in the directory but when I try to play the sound I get
the following error incase of gsm

AGI Rx < < STREAM FILE /var/sounds/145712900 "" 0
[May 24 14:00:07] WARNING[22415][C-0000019c]: file.c:492 filehelper: File
/var/sounds/145712900.gsm detected to have zero size.

and the following error incase of wav file format

AGI Rx < < STREAM FILE /var/sounds/1886163042 "" 0
[May 24 14:07:07] WARNING[22587][C-0000019e]: format_wav.c:159
check_header: Does not begin with RIFF
[May 24 14:07:07] WARNING[22587][C-0000019e]: file.c:393 fn_wrapper: Unable
to open format wav
AGI Tx >> 200 result=0 endpos=0

Unable to execute ‘dahdi_scan > /etc/asterisk/dahdi_scan.conf’

On Wed, May 23, 2012 at 02:02:51PM +0500, p070075 Muhammad Atif Ramzan wrote:
> Hi
>
> Can anyone help me with this error
> Unable to execute ‘dahdi_scan > /etc/asterisk/dahdi_scan.conf’
>
> i am using asterisk-gui 2.0 , asterisk 1.8, dahdi 2.6 and also my call
> reached the destination but no voice is coming from destination my voice
> reflects back

Have you verified the user asterisk is running as can execute
dahdi_scan? This was asked not too long ago on the forums as well:

http://forums.asterisk.org/viewtopic.php?f=1&t=82659

Unable to execute ‘dahdi_scan > /etc/asterisk/dahdi_scan.conf’

Hi

Can anyone help me with this error
Unable to execute ‘dahdi_scan > /etc/asterisk/dahdi_scan.conf’

i am using asterisk-gui 2.0 , asterisk 1.8, dahdi 2.6 and also my call
reached the destination but no voice is coming from destination my voice
reflects back

thanks

parsing issue

I get an error when I execute this code
exten => rejected,n,Hangup($[-1*${Z}])

May 2 13:42:09] WARNING[23128]: ast_expr2.fl:468 ast_yyerror:
ast_yyerror(): syntax error: syntax error, unexpected $end, expecting
‘-’ or ‘!’ or ‘(‘ or ‘‘; Input:
-1*

The variable “Z” has a negative number, which is the code that I need
to use in the hangup.
Any idea how can I do this? There is no ABS() function in Asterisk. I
already filed a request for it but it turns up that it will cost me
money. How can I remove the sign from a number?
Philip