Question on system command 1.4.43

Report
Question

I have a USB to serial converter attached to my box. pl2303: Prolific
PL2303 USB to serial adaptor driver
if I login to the box and send/receive serial commands over this unit it
works without error EVERY time. however, if I run the same command set from with-in the extensions.conf
with System()
I get errors in dmesg like "pl2303 ttyUSB0: pl2303_open - failed
submitting read urb, error -22"
and then obviusly my command does not work. however, again - If I go back to the command line and my command it runs

Asterisk Users 3.6 years ago 5 Answers

BRI confiugration error

Report
Question

Hi sir, I was installed Goautodial server and I have b410p BRI card. BRI card
showing OK with dahdi_tool, this NT mode.
whenever I am dialing from server i am not able to connect the call . in Cli
below mention warning is comming .
please what is the mistake with me . help me
Executing [0559566768@default:1] AGI("Console/dsp", "agi://
127.0.0.1:4577/call_log") in new
stack

Asterisk Users 4.2 years ago 4 Answers

console.conf.sample in 1.8.3

Report
Question

In console.conf.sample it says run the command "console list available"
CLI command. It does not seem to be present:
console list available
No such command 'console list available' These are the only console commands I see: console answer Answer an incoming console call
console autoanswer Sets/displays autoanswer
console dial Dial an extension on the console
console hangup Hangup a call on the console
console send text Send text to the remote device
console {mute|unmute} [toggle] Disable/Enable mic input Is chan_console just a super set of chan_alsa? In 1.4 Console/Dsp was ALSA, is…

Asterisk Users 4.5 years ago 0 Answers

Busy Detection on Analog Lines

Report
Question

Hi, I'm having an issue with busy detection, the busy is not being detected. Asterisk: 1.6.2.13 DAHDI: 2.4.0 Chandahdi: busydetect=yes, busycount=2 Indications zone = us, with the modifications for my country for busy: 425Hz Pattern(0.2ms on, 0.2ms off, 0.2ms on, 0.6ms off) I compiled with BUSY DETECT DEBUG. I can see: [Feb 10 15:48:06] DEBUG[26968]: dsp.c:1276 ast_dsp_busydetect: busy
detector: FAILED with avgtone: 255, avgsilence 30 [Feb 10 15:48:06] DEBUG[26968]: dsp.c:1276 ast_dsp_busydetect: busy
detector: FAILED with avgtone: 255, avgsilence 30 [Feb 10 15:48:06] DEBUG[26968]: dsp.c:1276 ast_dsp_busydetect: busy
detector: FAILED with avgtone: 255, avgsilence 30 [Feb 10 15:48:40] DEBUG[26971]:…

Asterisk Users 4.5 years ago 0 Answers

no audio

Report
Question

Any reason why I don't get audio on the channel after it rings and the
end user picks up.
Here are my files.
CONSOLE=Console/dsp ; Console interface for demo
OUTBOUNDTRUNK=SIP/callwithus [default]
include => stdexten
exten => s,1,Answer()
exten => s,n,Wait(1)
exten => s,n,Dial(SIP/callwithus/1111444444,120,A,(demo-thanks))
exten => s,n,Wait(2)
exten => s,n,Hangup()
my sip.conf file [general]
context=default
allowoverlap=no
bindport=5060
port=5060
bindaddr=0.0.0.0
canreinvite=no ;if your asterisk box is behind a NAT ro ;register => xxx:yyy@carrier.callwithus.com
register => xxx:yyy@sip.callwithus.com [callwithus]
type=friend
host=sip.callwithus.com

Asterisk Users 4.7 years ago 5 Answers

quick 1.8 question on console/dsp

Report
Question

In 1.4 I used alsa.conf and Dial(Console/Dsp) In 1.8 this is not working (as I had it) . I know there is a new
chan_console
I'd like to try both. What is the correct Dial() for ALSA direct?
What is the correct Dial() for chan_console? I "thought" if chan_alsa was loaded it would default to old behaviour
if chan_console was not loaded. Thanks, jerry

Asterisk Users 4.9 years ago 0 Answers