No progress tones on transferred call

Report
Question

Asterisk 1.4
We are experiencing an issue on transfers where no progress tones are heard
by the caller:
1. Call from 1593 (SPA525G 0026998D2FFFF) to 1595 (SPA922 000B820AFFFFF).
1595 answers
2. From 1593 initiate transfer to 1597 (SPA508G 1CDF0F4AFFFF). 1595 hears
MoH.
3. 1597 starts ringing and 1593 presses transfer again. MoH stops but 1595
hears no ringing
When xfer is pressed and the extension is dialled:
U 203.89.001.001:5060 -> 121.98.001.001:1034
INVITE sip:1CDF0F4AFFFF@192.168.1.72:5060 SIP/2.0..Via: SIP/2.0/UDP
203.89.001.001:5060;branch=z9hG4bK5286810e;rport..From: "C Allerid"
;tag=as72616c50..To:
..Contact:
..Call-ID:

Asterisk Users 3.1 years ago 0 Answer

Upgrade from version 1.6.24 to 1.8.12 - Retransmission timeout error

Report
Question

Hi list, we are upgrading our Asterisk production server from 1.6.24 to 1.8.12
version and face the following problem: one of our peer
(voicetrading.com) doesn't accept our calls anymore, we receive a
timeout error "Packet timed out after 32000ms with no response". Switching back to 1.6 make things working again! In sip.conf we have nat=no, peer conf is: [myPeerDef]
type=peer
host=111.111.1.111
context=honeypot
insecure=invite
directmedia=no
disallow=all
allow=ulaw,alaw
dtmfmode=inband We aren't registered, our IP is authorized by their system. Debug of sessions (222.222.22.22 is our server…

Asterisk Users 3.1 years ago 7 Answer

When CALL-ID were same , I could hijack another session

Report
Question

Hello all. I want to know this issue is bug or not. My Asterisk version is 1.6.2.6.
I used "nat=yes" on sip.conf. ##################################
Issue 1. SDP session handring by Asterisk
################################## I used 2 clients , A and B. 2 UAC under another NAT. ///////////////////////////////

Asterisk Users 3.3 years ago 0 Answer

Problem while sending SIP NOTIFY via AMI in 1.8.10-rc2

Report
Question

Hi, while testing asterisk 1.8.10-rc2 I stumbled across a weird behavior. I
want to notify a snom phone to reload its configuration. For this to
happen, I use the NOTIFY mechanism. I started the notify via AMI
command. Asterisk is bound to udp 25060, because all phones are
registered with a local opensips proxy which uses 5060. The expected
behavior would be:
asterisk send SIP NOTIFY to the proxy, the proxy sends it to the phone. Actually asterisk sends the packet to the proxy, but the contact header
contains something invalid (IMHO): On…

Asterisk Users 3.4 years ago 1 Answer