Queue Show : Failed To Extend From 240 To 327

Home » Asterisk Users » Queue Show : Failed To Extend From 240 To 327
Asterisk Users 4 Comments

Hello

when I type on the Asterisk CLi ‘queue show’, I first get a list of my queues and then the following :

failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 323
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 323
failed to extend from 240 to 323
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 323
failed to extend from 240 to 334
failed to extend from 240 to 334
failed to extend from 240 to 334
failed to extend from 240 to 327
failed to extend from 240 to 327
failed to extend from 240 to 334
failed to extend from 240 to 334

I could not find any information on this on the web, except this :
https://issues.asterisk.org/jira/browse/ASTERISK-8828

which is an old ‘bug’ that should have been fixed meanwhile.

Any more thoughts on why I should be getting this message when asking information about queues (I don’t see this message on any other command).

Kind regards

Jonas.

4 thoughts on - Queue Show : Failed To Extend From 240 To 327

  • failed to extend from 240 to 334

    That message is a result of trying to build a string where the buffer is too small to contain it. I would expect that there is a truncated string in the
    ‘queue show’ output.

    You haven’t stated which Asterisk version you are using. It may already be fixed.

    Richard

  • Hello

    I have this with asterisk-certified-13.8-cert1 and also with asterisk-certified-13.8-cert2

    Could it be that the membername value (and interface value) in my realtime MySQL table queue_members is too long ??

    It looks like this :

    Local/01_vlaebidvxcrxrheebdin354@ExternalCallFromQueue Local/02_vlaebidvxcrxrheebdin114@ExternalCallFromQueue Local/03_vlaebidvxcrxrheebdin329@ExternalCallFromQueue

    I have the idea that this is the “problem”.

    FYI : it also makes that Asterisk restarts (with core dump) whenever a queue is addressed. Very /annoying/ !

    So string size too large and buffer too small.

    FYI : I do not have this with any version of Asterisk 1.8. This is a
    “problem” that exists only in Asterisk 13.

    How to fix this ??

    Kind regards.

    Jonas.

  • This is an example output for queue show < > on Asterisk version asterisk-certified-13.8-cert2 (same on asterisk-certified-13.8-cert1) :

    sip*CLI> queue show cvikbubohirndceiaetsq cvikbubohirndceiaetsq has 0 calls (max unlimited) in ‘ringall’ strategy
    (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 0s
    Members:
    cvikbubohirndceiaets012
    (Local/cvikbubohirndceiaets012@ExternalCallFromQueue from Local/cvikbubohirndceiaets012@ExternalCallFromQueue) (ringinuse disabled) (realtime) (Not in use) has taken no
    cvikbubohirndceiaets248
    (Local/cvikbubohirndceiaets248@ExternalCallFromQueue from Local/cvikbubohirndceiaets248@ExternalCallFromQueue) (ringinuse disabled) (realtime) (Not in use) has taken no
    cvikbubohirndceiaets428
    (Local/cvikbubohirndceiaets428@ExternalCallFromQueue from Local/cvikbubohirndceiaets428@ExternalCallFromQueue) (ringinuse disabled) (realtime) (Not in use) has taken no
    cvikbubohirndceiaets461
    (Local/cvikbubohirndceiaets461@ExternalCallFromQueue from Local/cvikbubohirndceiaets461@ExternalCallFromQueue) (ringinuse disabled) (realtime) (Not in use) has taken no
    cvikbubohirndceiaets629
    (Local/cvikbubohirndceiaets629@ExternalCallFromQueue from Local/cvikbubohirndceiaets629@ExternalCallFromQueue) (ringinuse disabled) (realtime) (Not in use) has taken no
    No Callers

    failed to extend from 240 to 327
    failed to extend from 240 to 327
    failed to extend from 240 to 327
    failed to extend from 240 to 327
    failed to extend from 240 to 327

    Any idea on how to fix this ??

    Kind regards.

    J.