Asterisk / SIP-Call / AGI-Script / SIGHUP After Answer

Home » Asterisk Users » Asterisk / SIP-Call / AGI-Script / SIGHUP After Answer
Asterisk Users No Comments

Hi,

I am facing a (for me) strange problem. When placing a SIP-Call I
normally get connected and the dialplan is executed. The Call-Flow is controlled by a PHP-Agi-Script. The script answers the call (via AGI-Command) and a simple voicefile is played. SOMETIMES(!) I get disconnected immediately after the Answer – without any reason. This happens about all fifth call.

Later on you will find my SIP-Debug-Output. I can see a “BYE”-Message. But why?

AGI-Debug-Messages:
(yes – I can the result is -1 > but why? Normally it is 0)

<-- snip -->
AGI Rx << Answer AGI Tx >> 200 result=-1
<-- snip -->

SIP-Debug-Messages:

<-- snip -->
<--- SIP read from UDP:217.92.105.86:51861 --->
INVITE sip:3@myhost.org SIP/2.0
Via: SIP/2.0/UDP
192.168.1.2:51861;rport;branch=z9hG4bKPj47b1a62ac3744acd996426618d90388f Max-Forwards: 70
From: “Thorsten (myhost)”
;tagC13e82f4af9423bab056113e5e05713
To:
Contact:
Call-ID: a19e81e8a2d74f718e1263ab3fd3b328
CSeq: 28484 INVITE
Allow: SUBSCRIBE, NOTIFY, PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, MESSAGE, REFER
Supported: 100rel, replaces, norefersub, gruu User-Agent: Blink 0.5.0 (Windows)
Content-Type: application/sdp Content-Length: 386

v=0
o=- 3589198761 3589198761 IN IP4 192.168.1.2
s=Blink 0.5.0 (Windows)
c=IN IP4 192.168.1.2
t=0 0
m=audio 10054 RTP/AVP 108 99 98 9 0 8 96
c=IN IP4 192.168.1.2
a=rtcp:10055
a=rtpmap:108 opus/48000
a=rtpmap:99 speex/32000
a=rtpmap:98 speex/16000
a=rtpmap:9 G722/8000
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:96 telephone-event/8000
a=fmtp:96 0-15
a=sendrecv
<------------->
— (13 headers 17 lines) –