H.323 Trunk Between Asterisk Voip Software And Avaya

Home » Asterisk Users » H.323 Trunk Between Asterisk Voip Software And Avaya
Asterisk Users No Comments

I’m trying to create a H.323 trunk between Asterisk 11 and Avaya. I have done this before between Asterisk 1.6 and Avaya but had some issues placing external calls from the Asterisk to the Public network which is connected to Avaya. I’m trying to create that trunk on Asterisk 11 because the 1.6 is outdated and has no support.

On theĀ VoIP software side

On the Asterisk side I have Aastra 6731i SIP phones and on the Avaya I’m using only H.323 phones. So far I can call from Asterisk to Avaya but there’s no sound and when calling from Avaya to Asterisk the call is dropped.

Here are my config files:

sip.config:

[general]
allowguest=no srvlookup=no udpbindaddr=192.168.1.252 ; IP of the Asterisk box tcpenable=yes ; if I set it to no I can’t call between the Aastra phones

[office-phone](!)
type=friend secret=1234
context=LocalSets host=dynamic nat=force_rport,comedia dtmfmode=auto disallow=all allow=alaw allow=ulaw port=5060

[426](office-phone)
[427](office-phone)

ooh323.conf:

[general]
port=1720
bindaddr=0.0.0.0
gateway=no canreinvite=no faststart=yes h245tunneling=yes h323id=ObjSysAsterisk e164=100
callerid=asterisk gatekeeper = DISABLE
context=trunk disallow=all allow=alaw allow=ulaw dtmfmode=outofband

[avaya]
type=friend ip=192.168.1.150 ; IP address of the Avaya port=1720

extensions.conf:

[general]
static=yes writeprotect=no autofallthrough=yes clearglobalvars=no

[trunk]
exten=>_8xx,1,Dial(OOH323/${EXTEN}@AVAYA)
exten=>_426,1,Dial(SIP/${EXTEN})
exten=>_427,1,DialIP/${EXTEN})

[LocalSets]
include=>trunk

When I try to place a call from Avaya to Asterisk this is what appears on the CLI:

— Executing [426@trunk:1] Dial(“OOH323/avaya-2”, “SIP/426”) in new stack
== Using SIP RTP CoS mark 5
— Called SIP/426
== Spawn extension (trunk, 426, 1) exited non-zero on ‘OOH323/avaya-2’

When I make a call from Asterisk to Avaya this is the output, the last line appears when I hang the call:

== Using SIP RTP CoS mark 5
— Executing
[821@LocalSets:1] Dial(“SIP/426-00000003”,
“OOH323/821@AVAYA”) in new stack
— Called OOH323/821@AVAYA
— OOH323/avaya-3 is ringing
— OOH323/avaya-3 answered SIP/426-00000003
> 0xb6d02370 — Probation passed – setting RTP source address to
192.168.1.215:3000
== Spawn extension (LocalSets, 821, 1) exited non-zero on
‘SIP/426-00000003’

Hope you can give me a guide on what to change in order to get this trunk to work.

Thank you.