DAHDI 2.6 And OPENVOX Cards

Home » Asterisk Users » DAHDI 2.6 And OPENVOX Cards
Asterisk Users 5 Comments

B.H.

Hello, all 🙂

We have some OPENVOX D410P PRI cards and we are successfully using them with Asterisk boxes which are based on stock ubuntu 12.04 DAHDI and Asterisk packages.

The card is recognized by DAHDI as ‘Wildcard TE410P (2nd Gen)’ and it uses wct4xxp driver.

Now, i’m trying to run this hardware with DAHDI 2.6.2 package which is available from asterisk.org site and looks like, it is not working with my card – i’ve compiled and configured it. It recognizes my card, but after loading dahdi and the config, the card is not functional – it shows green lights even when no E1 cable connected, and dahdi_test gives 0.0% all the time so looks like it doesn’t generate interrupts.

Thanks for your help 🙂

5 thoughts on - DAHDI 2.6 And OPENVOX Cards

  • B.H.

    Thanks for the reply

    the output for the relevant card is:

    # lspci -n
    04:01.0 0780: d161:0410 (rev 02)

    #lspci
    04:01.0 Communication controller: Digium, Inc. Wildcard TE410P/TE412P
    quad-span T1/E1/J1 card 3.3V (rev 02)

  • Strange that another manufacturer is using Digium’s pci vendor and device ids. This is not a bug in DAHDI. If this card ever worked with DAHDI, it’s only by coincidence. You’ll probably need to contact your manufacturer for support.

  • B.H.

    Thanks! The patched version worked 100%. Don’t ask me why they use Digium’s ids 🙂