Getting Unknown Error While Configuring Asterisk With Linux HA

Home » Asterisk Users » Getting Unknown Error While Configuring Asterisk With Linux HA
Asterisk Users No Comments

Hi,

I recently configured Linux HA for Asterisk service (using Asterisk resource agent downloaded from link:
https://github.com/ClusterLabs/resource-agents/blob/master/heartbeat/asterisk
). As per configuration it is working good but when I include “monitor_sipuri=”
sip:42@10.3.152.103″ ” parameter in primitive section it is giving me an errors like listed below;

root@asterisk2 ~> crm_mon -1

===========
Last updated: Thu Mar 28 06:09:54 2013

Stack: Heartbeat

Current DC: asterisk2 (b966dfa2-5973-4dfc-96ba-b2d38319c174) – partition with quorum

Version: 1.0.12-unknown

2 Nodes configured, unknown expected votes

1 Resources configured.

===========

Online: [ asterisk1 asterisk2 ]

Resource Group: group_1

asterisk_2 (lsb:asterisk): Started asterisk1

IPaddr_10_3_152_103 (ocf::heartbeat:IPaddr): Started asterisk1

Failed actions:

p_asterisk_start_0 (node=asterisk1, calld, rc=1, status=complete):
unknown error

p_asterisk_start_0 (node=asterisk2, call , rc=1, status=complete):
unknown error

I tested the ‘sipsak’ tool on cli, it is executing without any issue i.e. returning 200 OK but when I remove this “param monitor_sipuri” I’m not getting the errors and also I created sip profile ’42’ without setting any password, tested first on softphone and is working.

Test result for sipsak;

root@asterisk1 ~> sipsak -v -s sip:42@10.3.152.103
SIP/2.0 200 OK
Via: SIP/2.0/UDP 10.3.152.105:60928
;branch=z9hG4bK.274e15e9;alias;received.3.152.103;rport`928
From: sip:sipsak@10.3.152.105:60928;taghc5c65d To: sip:42@10.3.152.103;tag=as558d9271
Call-ID: 1757791837@10.3.152.105
CSeq: 1 OPTIONS
Server: Asterisk PBX 10.12.1
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer Contact:
Accept: application/sdp Content-Length: 0

Listing down the configuration below which I configured;

node $id=”887bae58-1eb6-47d1-b539-d12a2ed3d836″ asterisk1
node $id=”b966dfa2-5973-4dfc-96ba-b2d38319c174″ asterisk2
primitive IPaddr_10_3_152_103 ocf:heartbeat:IPaddr \
op monitor interval=”5s” timeout=”20s” \
params ip=”10.3.152.103″
primitive p_asterisk ocf:heartbeat:asterisk \
op monitor interval=”10s” \
params realtime=”true”
group group_1 p_asterisk IPaddr_10_3_152_103 \
meta target-role=”Started”
location rsc_location_group_1 group_1 \
rule $id=”preferred_location_group_1″ 100: #uname eq asterisk1
colocation asterisk-with-ip inf: p_asterisk IPaddr_10_3_152_103
property $id=”cib-bootstrap-options” \
symmetric-cluster=”true” \
no-quorum-policy=”stop” \
default-resource-stickiness=”0″ \
stonith-enabled=”false” \
stonith-action=”reboot” \
startup-fencing=”true” \
stop-orphan-resources=”true” \
stop-orphan-actions=”true” \
remove-after-stop=”false” \
default-action-timeout=”120s” \
is-managed-default=”true” \
cluster-delay=”60s” \
pe-error-series-max=”-1″ \
pe-warn-series-max=”-1″ \
pe-input-series-max=”-1″ \
dc-version=”1.0.12-unknown” \
cluster-infrastructure=”Heartbeat”

And the status I’m getting is listed below;

root@asterisk1 ~> crm_mon -1
===========Last updated: Fri Mar 29 12:25:10 2013
Stack: Heartbeat Current DC: asterisk1 (887bae58-1eb6-47d1-b539-d12a2ed3d836) – partition with quorum Version: 1.0.12-unknown
2 Nodes configured, unknown expected votes
1 Resources configured.
===========
Online: [ asterisk1 asterisk2 ]

Resource Group: group_1
p_asterisk (ocf::heartbeat:asterisk): Started asterisk1
IPaddr_10_3_152_103 (ocf::heartbeat:IPaddr): Started asterisk1

Please advise to overcome this issue.