Chan_dahdi.c: No D-channels Available! Using Primary Channel 16 As D-channel Anyway!

Home » Asterisk Users » Chan_dahdi.c: No D-channels Available! Using Primary Channel 16 As D-channel Anyway!
Asterisk Users No Comments

Hi all. I have this problem with my Digium 2E1 card and PRI, for hours It works well, with some meesages…

[Aug 10 09:20:31] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1

But PRI continue up….hours later… PRI go down. I thought the problem was in the telco, but the strange thing is that I
have a loop cable in the second E1 and when I scan both E1 are with alarms=LMFA/OK and i have only the first E1 connected to the telco!!

messages
[Aug 10 09:20:31] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1
[Aug 10 09:20:32] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1
[Aug 10 09:20:32] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1
[Aug 10 09:20:32] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1
[Aug 10 09:20:32] NOTICE[32270] chan_dahdi.c: PRI got event: HDLC Abort (6)
on Primary D-channel of span 1
[Aug 10 09:20:36] WARNING[32270] chan_dahdi.c: No D-channels available!
Using Primary channel 16 as D-channel anyway!

gentoo1 ~ # dahdi_scan
[1]
active=yes alarms=LMFA/OK
description=T2XXP (PCI) Card 0 Span 1
name=TE2/0/1
manufacturer=Digium devicetype=Wildcard TE220 (5th Gen)
location=Board ID Switch 0
basechan=1
totchans1
irq
type=digital-E1
syncsrc=0
lbo=0 db (CSU)/0-133 feet (DSX-1)
coding_opts=AMI,HDB3
framing_opts