IMAP Voicemail

Hello all,

I quickly searched online prior to sending this, but if this was previously brought up, I sincerely apologize.

I noticed IMAP Voicemail remains as a build option in later versions of Asterisk 1.8 but the only latest version I’ve found working is 1.8.8.0.

Is this an error in the latest source, or will IMAP no longer be supported?

Also note, I am using C-Client v2007f.

Any insight to this issue is greatly appreciated.

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

3 Responses to “IMAP Voicemail”

  1. "Matthew Jordan" said:

    May 29, 12 at 8:05 am
  2. Jon Caum said:

    May 29, 12 at 12:42 pm

    In detail, I have tried both using the FreePBX distro, which uses packages – specifically Asterisk18-voicemail-imapstorage – and using PBX In A Flash, specifiying for Asterisk 1.8.8.0

    When I use src for Asterisk version greater than 1.8.8.0, and download the C-Client I specified earlier, compile it, and then run /usr/src/asterisk/make menuselect and then select IMAP under Voicemail Build Options, it compiles fine with no errors.

    However, when I connect to the CLI “asterisk -r” and type “module show like voice” It lists app_voicemail.so, but the description does not say “With IMAP”. Furtermore, the system does not ackowlede the IMAP parameters I specified in my server.

    As soon as I download and compile 1.8.8.0 and specify IMAP by running menuselect, I leave a message at an extension and it delivers to the mailbox. I can also observe in the Asterisk logs that it is communicating with our IMAP server, whereas the in newer versions of 1.8.x it does not.

    Also, with FreePBX distro it only works when I manually force the repos to look at the 1.8.8.0 packages. Then insalling Asterisk18-voicemail-imapstorage works fine.

    For a detailed list of my installation procedure, I created a post at the PIAF forums: http://www.pbxinaflash.com/community/index.php?threads/imap-voicemail.6321/

  3. Jon Caum said:

    Jun 19, 12 at 8:35 am

    It seems now that 1.8.13 now supports IMAP voicemail.

    I just installed a fresh copy of PBX In a Flash and opted to install Asterisk 1.8.13. It seems now that when built with ‘make menuselect’ (after downloading and making the IMAP client from UW and running ‘./configure –with-imap=/usr/src/imap’ (I placed the IMAP client src at /usr/src/imap) I can confirm that IMAP can connect to our IMAP server in the sky and deliver messages fine.

    Message-ID:

    Content-Type: text/plain; charset=”utf-8″

    In detail, I have tried both using the FreePBX distro, which uses packages – specifically Asterisk18-voicemail-imapstorage – and using PBX In A Flash, specifiying for Asterisk 1.8.8.0

    When I use src for Asterisk version greater than 1.8.8.0, and download the C-Client I specified earlier, compile it, and then run /usr/src/asterisk/make menuselect and then select IMAP under Voicemail Build Options, it compiles fine with no errors.

    However, when I connect to the CLI “asterisk -r” and type “module show like voice” It lists app_voicemail.so, but the description does not say “With IMAP”. Furtermore, the system does not ackowlede the IMAP parameters I specified in my server.

    As soon as I download and compile 1.8.8.0 and specify IMAP by running menuselect, I leave a message at an extension and it delivers to the mailbox. I can also observe in the Asterisk logs that it is communicating with our IMAP server, whereas the in newer versions of 1.8.x it does not.

    Also, with FreePBX distro it only works when I manually force the repos to look at the 1.8.8.0 packages. Then insalling Asterisk18-voicemail-imapstorage works fine.

    For a detailed list of my installation procedure, I created a post at the PIAF forums: http://www.pbxinaflash.com/community/index.php?threads/imap-voicemail.6321/