* You are viewing the archive for May 25th, 2012

Loss of RTP stream during DTMF collection

Hi Kevin,

I have two asterisk boxes with the same issues.
Box 1: asterisk ver 1.4.21.2
Box 2: Asterisk 1.8.7.1

setup:
CDMA Phone <> CDMA Media Gateway WCM Asterisk voice mail

The calls are SIP Based. DTMF collection is when the user is entering a
password for voice mail access or voucher to recharge their account.

voice mail:
user is prompted for a password. After password is entered I can see
asterisk playing the voice mail but no audio is heard on the phone.

Other scenario user dials into a voucher menu (Asterisk2billing) and is
prompted for a voucher. No audio after the voucher is entered.

The CDMA guys did a trace on their end and this is what they explained
is happening:

The voicemail problem is due to the time stamp jump on the RTP steam
sending WCM to BSC. There are about 5 seconds gap between two
consecutive RTP packets. It was caused by Asterisk not sending any RTP
packet to WCM.

How can I enable the option to allow asterisk to maintain the RTP stream
during DTMF collection?

Thanks,
Dave

> ——– Original Message ——–
> Subject: Re: [asterisk-users] Loss of RTP stream during DTMF collection
> From: “Kevin P. Fleming”
> Date: Fri, May 25, 2012 5:38 pm
> To: asterisk-users@lists.digium.com
>
>
> On 05/25/2012 04:30 PM, Dave George wrote:
> > I am using asterisk for voice mail. During DTMF collection Asterisk
> > stop sending any RTP Packets. The gap between two consecutive packets
> > are 4 seconds, which is huge enough to screw up the jitter buffer. When
> > ever asterisk stops to receive DTMF, the RTP stream is cut and we loose
> > audio.
> >
> > I don’t have this issue when calling from a SIP phone. I only have this
> > issue when calling from one media gateway to the asterisk box.
> >
> > Any suggestions welcome. Can I play some file in the back while
> > collecting DTMF?
>
> You are missing quite a lot of crucial information required for anyone
> to help you. First, what version of Asterisk are you using? Second, what
> type of channel is being used to connect to Asterisk? You mention it
> works from a SIP phone, but not from a media gateway.. is that gateway
> also using SIP, or something else? What does ‘during DTMF collection’
> mean? Do you mean after a prompt has been played and the voicemail
> application is waiting for input, or is this during prompt playback, or
> something else?
>
> Quite some time ago Asterisk was changed to ensure that silence would be
> sent while an application was running and waiting for input from the
> caller; if your version is older than this, then that could explain what
> you are seeing. That’s just a mildly-educated guess though.
>
> –
> Kevin P. Fleming
> Digium, Inc. | Director of Software Technologies
> Jabber: kfleming@digium.com | SIP: kpfleming@digium.com | Skype: kpfleming
> 445 Jan Davis Drive NW – Huntsville, AL 35806 – USA
> Check us out at www.digium.com & www.asterisk.org
>
> –
> _____________________________________________________________________
> — Bandwidth and Colocation Provided by http://www.api-digital.com
> New to Asterisk? Join us for a live introductory webinar every Thurs:
> http://www.asterisk.org/hello
>
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
> http://lists.digium.com/mailman/listinfo/asterisk-users

URA

Hi

Recently our asterisk system stopped beign recognized by URA in others
telephones exchanges. What’s the troubleshoot steps for this issue?

Huawei K3765-HV with Asterisk?

Hi again,

does someone use the USB-Stick “Huawei K3765-HV” with Asterisk?

I have an 4-Port TT-Hub (Cypress Chip) and 4 USB-Sticks with 4 different
GSM Provider (Germany, France, Turkey, and Iran)

Currently I use the “Vodafone Easybox 803 A” together with an ISDN
connection to my Asterisk Server, an analog telephone (PA710) and an USR
Sportster Vi 14.400 Fax-Modem (HylaFax).

Grmpf, I was not abele to send faxes from my workstations direktly using
Asterisk

And then the last question:

Does someone know, how the OpenSMS API is working?

The EasyBox 803A does support it and I need to get the SMS from the USB-
Stick. It is enough, if thex could be fetched and send as mail to me.

Thanks, Greetings and nice Day/Evening
Michelle Konzack

Dual- or Quad ISDN cards for PCI-X Slots

Hello ISDN Users.

I am hit by some frustrations because my Server has only two PCI-X slots
and my Eicon Diva 4BRI-8M, which should work fine with Asterisk, is only
PCI 2.0 standard and does not fit into the PCI-X slot.

Currently I use two AVM Fritz! cards, but while my Xeon 604 2000MHz had
a load-average of less then 0.5 it is now increasing to more then 4, if
I have 20 VoIP and two ISDN calls.

So, the cheap AVM cards have to replaced.

Since I do not have currenly the money to buy a Eicon Diva Server 3.0
quad-port, can you recommend me inexpensive Dual- or Quad-Port cards
which I could get used on eBay?

Note: I have to connect my Alice Box (ADSL2+) and two Vodafone
EasyBox 803A (using the Huawei K3765-HV USB-Stick) to it.

Thanks, Greetings and nice Day/Evening
Michelle Konzack

Function not Registered??

Hi all,

I am running the same Asterisk 1.4.21.2 with the same configuration on all the servers in the region.

I got this function called func_devstate which I use to control the lights of the Polycom phones.

This module works well for all the Asterisk servers except this one.

To get it to work, I basically compile this module together with the others and there is no need to explicitly load it in modules.conf.

The problem is when my script uses function DEVSTATE, the Asterisk console shows that it is not registered.

However, when I did a module show, it was there.

I did restart Asterisk or include it in module.conf but it did not resolve the problem.

Do you have any clues why this is happening?

Thanks in advance.