SET SIP_CODEC and Video issues

Home » Asterisk Users » SET SIP_CODEC and Video issues
Asterisk Users 2 Comments

Greetings List.
I Have a small test server and i’m facing a small issue.
i have setup two SIP PEERS and they are able to do Video calls.
now I’m testing SET SIP_CODEC in a dial plan and when ever i’m setting the codec .. the inbound (=first) leg stops receiving or sending video and SIP SHOW CHANNELS shows only the Codec i set in the dialplan.
is it possible to avoid this problem?

Asterisk version
1.8.11.0

SIP.CONF
=======

[TK1000]
type=friend
secret=0jCiOdT81P
videosupport=yes
qualify=yes
host=dynamic
dtmfmode=rfc2833
context=DER-TEST
canreinvite=yes
disallow=all
allow=ulaw,alaw,gsm,h263,h263p

[TK1000]
type=friend
secret=0jCiOdT81P
videosupport=yes
qualify=yes
host=dynamic
dtmfmode=rfc2833
context=DER-TEST
canreinvite=yes
disallow=all
allow=ulaw,alaw,gsm,h263,h263p

EXTENSIONS.CONF
[DER-TEST]
;exten => _.,1,NoCDR()
exten => _.,1,Set(SIP_CODEC=alaw)
exten => _.,2,Set(SIP_CODEC_OUTBOUND=gsm)
;exten => _.,2,Set(SIP_CODEC_INBOUND=gsm)
exten => _.,n,DIAL(SIP/TK${EXTEN})
exten => h,1,Hangup()

Tarek Sawah

Information Technology Adviser

Integrated Digital Systems

CCNP, MCSE, RHCE, TELECOM

USA: +1 386 492 9993

2 thoughts on - SET SIP_CODEC and Video issues

  • Of course you are disabling the video maybe also include the video protocols in the sip_codec

  • Thank you, Any idea how?
    Need to be able to control the codecs in use
    through soem bandwidth tests. so i need to be able to set the SIP_CODEC
    and still be able to do Video.
    any suggestions?