Is Asterisk 10 available in Digium Repository? I doesn’t show up

Home » Asterisk Users » Is Asterisk 10 available in Digium Repository? I doesn’t show up

5 thoughts on - Is Asterisk 10 available in Digium Repository? I doesn’t show up

  • There are now repositories for each major version of Asterisk, which have to be
    explicitly enabled to use them.

    `yum update` to get to the latest of everything, then do `yum update

  • Thanks Jason.

    One more question: Is there anyway to go back on an Asterisk version when
    using the repository? For example, Asterisk 1.8.9.2 is available now. But I
    want to use 1.8.9.1. Can I downgrade somehow? I want to test NAT bug issue.

    Thanks

  • yum downgrade is extremely broken. It fails, often, potentially leaving a
    system in an unrecoverable state. That is not to mention how poorly conceived
    the concept is. Consider what would happen if a package upgraded some resource
    to a non-backwards-compatible version.

    It is completely unsupported on the Digium repositories. Please don’t try it –
    I will not help fix it.

  • This is generally true of *all* software packages; the
    developers/maintainers provide mechanisms for upgrading, but not
    downgrading. “simple” downgrades should be possible, but the packages
    aren’t marked in any way to indicate whether that could even be done.