asterisk problem sip

Home » Asterisk Users » asterisk problem sip
Asterisk Users 2 Comments

Hi everybody

I have been presenting a periodic problem, do not know if anyone listed has
happened something similar,I’m using the asterisk, asterisk-1.6.2.13, in
different locations works well, but every so often fails, hangs on Asterisk
server or simply asterisk, SIP requirements do not answer, apparently
unaware of the dialplan as well as voicemails, etc, but keeps the
registry, apparently the service is up but theusers, call and doesn’t make
calls.

Asterisk is restarted, and solve the problem, I think it may be a bug in
asterisk, someone has had a similar problem?

Regards

Carlos

2 thoughts on - asterisk problem sip

  • Sounds like you’ve run in to a deadlock problem.

    Running ‘core show locks’ at the asterisk CLI, will show you that you have a
    lock, but debugging this is fun.
    To be able to use ‘core show locks’ you need ‘DEBUG THREADS’ and ‘DONT
    OPTIMIZE’ enabled in ‘make menuslect’

    However, 1.6.22 is the lastest.

    Alec Davis

    _____

    [mailto:asterisk-users-bounces@lists.digium.com] On Behalf Of Carlos Rojas
    Sent: Saturday, 14 January 2012 3:37 p.m.

    Hi everybody

    I have been presenting a periodic problem, do not know if anyone listed has
    happened something similar,I’m using the asterisk, asterisk-1.6.2.13, in
    different locations works well, but every so often fails, hangs on Asterisk
    server or simply asterisk, SIP requirements do not answer, apparently
    unaware of the dialplan as well as voicemails, etc, but keeps the registry,
    apparently the service is up but theusers, call and doesn’t make calls.

    Asterisk is restarted, and solve the problem, I think it may be a bug in
    asterisk, someone has had a similar problem?

    Regards

    Carlos

  • Hi,

    Thanks a lot, for your help, I found, much iformation about that will test
    the bugs, for asterisk

    Regards

    carlos