trying to build 1.8.6.0 on CentOS 6, problems with ptlib

Home » Asterisk Users » trying to build 1.8.6.0 on CentOS 6, problems with ptlib
Asterisk Users 2 Comments

I’m having annoying errors trying to get configure working.

tar xvzf /usr/local/src/asterisk-1.8.6.0.tar.gz
cd asterisk-1.8.6.0
./configure

I get complaints related to pwlib / ptlib…

checking for openr2_chan_new in -lopenr2… no
checking /root/pwlib/include/ptlib.h usability… no
checking /root/pwlib/include/ptlib.h presence… no
checking for /root/pwlib/include/ptlib.h… no
checking /usr/local/include/ptlib.h usability… no
checking /usr/local/include/ptlib.h presence… no
checking for /usr/local/include/ptlib.h… no
checking /usr/include/ptlib.h usability… yes
checking /usr/include/ptlib.h presence… yes
checking for /usr/include/ptlib.h… yes
checking for ptlib-config… /usr/bin/ptlib-config
./configure: line 24978: 2*10000+6*100+5 /usr/lib64/ /usr/lib/:
division by 0 (error token is “/lib64/ /usr/lib/”)

There seems to also be a problem with CentOS 6 in general that I have
not found a package that actually provides /usr/bin/ptlib-config. I
copied that binary over from a CentOS 5 install to see if I could get
my original error to clear.

Here’s THAT error…

checking for openr2_chan_new in -lopenr2… no
checking /root/pwlib/include/ptlib.h usability… no
checking /root/pwlib/include/ptlib.h presence… no
checking for /root/pwlib/include/ptlib.h… no
checking /usr/local/include/ptlib.h usability… no
checking /usr/local/include/ptlib.h presence… no
checking for /usr/local/include/ptlib.h… no
checking /usr/include/ptlib.h usability… yes
checking /usr/include/ptlib.h presence… yes
checking for /usr/include/ptlib.h… yes
checking for ptlib-config… no
./configure: line 24906: –ldflags: command not found
Cannot find ptlib-config – please install and try again

And then I searched around the config trying to figure out how not to
use ptlib at all, and ultimately I tried just doing…

rpm -e ptlib ptlib-devel (and the other packages)

And this got my asterisk configure to complete.

But really, I’m wondering if other people have run into the same
problem, or if there is a nifty configure argument that would keep me
from needing to uninstall the library.

2 thoughts on - trying to build 1.8.6.0 on CentOS 6, problems with ptlib

  • First, have you tried ./configure –help?
    Next try the –with-pwlib parameter
    Somewhere in the list, make sure your YUM paths are happy.

  • No. Asterisk does not use the configuration system used by the Linux
    kernel (Kbuild). Don’t confuse ‘menuconfig’ with ‘menuselect’.