Asterisk 1.8.5 – Ubuntu Pkg from diguim Repo – OPENH323 error

Home » Asterisk Users » Asterisk 1.8.5 – Ubuntu Pkg from diguim Repo – OPENH323 error
Asterisk Users No Comments

Hi Paul,

Maybe you can give some help here:

I’m trying to compile and build the debian source file
of asterisk_1.8.5.0.orig.tar.gz
and asterisk_1.8.5.0-1digium1~natty.debian.tar.gz.
Howerver every time I’m trying to compile it, using ./configure of
dpkg-buildpackage -rfakeroot -us -uc I get errors like this:

checking for mandatory modules: CAP GSM OPENH323 IMAP_TK PWLIB… fail

configure: ***
configure: *** The OPENH323 installation appears to be missing or broken.
configure: *** Either correct the installation, or run configure
configure: *** including –without-h323.

configure: ***
configure: *** The PWLIB installation appears to be missing or broken.
configure: *** Either correct the installation, or run configure
configure: *** including –without-pwlib.
make: *** [config.status] Error 1
dpkg-buildpackage: error: debian/rules build gave error exit status 2
root@FreePBX:/opt/asterisk/asterisk-1.8.5.0#

I do have the dev files and all required pkg installed, but still no good.

I manage u did compile it with these option on

Can u maybe tell what u did?

Thanks