Asterisk 1.8 Install Problem

Home » Asterisk Users » Asterisk 1.8 Install Problem
Asterisk Users 1 Comment

Hi list,
I have a problem with installing Asterisk (under
https://wiki.asterisk.org/wiki/display/AST/Asterisk+Packages):

sudo apt-get install asterisk-1.8
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘asterisk’ instead of ‘asterisk-1.8’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
asterisk : Depends: asterisk-core-sounds-en-gsm (>= 1.4.21) but it is not
going to be installed
E: Broken packages

Thank you for your help

One thought on - Asterisk 1.8 Install Problem

  • What distribution are you using? From the messages, it looks as though it
    could be Debian Sid or Wheezy, or possibly Ubuntu. You could try
    $ sudo apt-get install asterisk-core-sounds-en-gsm
    and see if that helps.

    What you might well have going on is a repository conflict, where apt wants to
    install incompatible packages from different repositories.

    I’ve personally never bothered with pre-compiled Asterisk packages. Just
    apt-get purge it (so that apt won’t interfere with your installation in
    future), and build the latest version from the Source Code.