Question on pause in dialing

Home » Asterisk Users » Question on pause in dialing
Asterisk Users 3 Comments

I am using asterisk 1.4.41 and polycom phones.
When I dial long distance I hear a pause on the last 2 digits.

This is the dialout context that matches.

[ Context ‘smvoice-dialout’ created by ‘pbx_config’ ]
‘_71XXXXXXXXXX’ => 1. Set(CALLERID(number)=3175551212)
[pbx_config]
2. Dial(DAHDI/g1/${EXTEN:1})
[pbx_config]
‘_7XXXXXXX’ => 1. Set(CALLERID(number)=3175551212)
[pbx_config]
2. Dial(DAHDI/g1/317${EXTEN:1})
[pbx_config]

So when I click “new call”, and dial 7 1 3 1 7 5 0 6 x x then I get a
pause before I can continue
entering the last two digits x x .

Why is that and how can I remove it.

Thanks,

Jerry

3 thoughts on - Question on pause in dialing

  • Try setting echotraining=no in chan_dahdi.conf.

    IIRC that pause is for the echotraining to train the echo canceler.

  • Eric,

    Is there another setting ? This had no effect.

    This is happening while I am entering the number to dial, I have not
    even hit the “Dial” button
    yet on the phone. I hit “New Call”, start entering my number, before I
    enter the last 2 digits
    I hear dial tone for a second or two then it goes back to the regular
    sound I heard when I hit “New call”.
    Then I hit dial and the call is placed. Its the pause and hearding the
    dial tone I am wanting to remove.

    THanks,

    jerry