No D-channels available! Using Primary channel as D-channel anyway!

Home » Asterisk Users » No D-channels available! Using Primary channel as D-channel anyway!
Asterisk Users No Comments

Its probably not a bug so don’t apply this patch. No D-Channel means
it cant sync up. It could be related to anything but the least likely
is that its a bug in libpri or dahdi.
Just go thru your configs, check and double check the cabling.

On Tue, Jun 14, 2011 at 7:27 PM, bilal ghayyad wrote:
> Dear;
>
> Thanks a lot for guiding me.
>
> Is it possible that the installation libpri-1.4.11.5 newer than the libpri-1.4.11.5-patch?
>
> Well, when I typed (note: I am trying to apply the libpri-1.4.11.5-patch for the libpri-1.4.11.5):
>
> libpri-1.4.11.5# patch -p0 -i libpri-1.4.11.5-patch
>
> It gave me that patched detected as shown below (example of one file, and I got same for other files):
>
> patching file pri.c
> Reversed (or previously applied) patch detected!  Assume -R?
>
> And when I reached to the q931, then it failed to save and apply the hunk !!
>
>
> patching file q931.c
> Hunk #1 succeeded at 601 (offset 280 lines).
> Hunk #2 FAILED at 4945.
> Hunk #3 FAILED at 4957.
> Hunk #4 FAILED at 4973.
> Hunk #5 FAILED at 5001.
> Hunk #6 FAILED at 5303.
> Hunk #7 FAILED at 5319.
> Hunk #8 FAILED at 5817.
> Hunk #9 FAILED at 5830.
> Hunk #10 FAILED at 6085.
> Hunk #11 FAILED at 6236.
> Hunk #12 FAILED at 6379.
> Hunk #13 FAILED at 6447.
> Hunk #14 FAILED at 6635.
> Hunk #15 FAILED at 7287.
> Hunk #16 FAILED at 7320.
> Hunk #17 FAILED at 7332.
> Hunk #18 FAILED at 7426.
> Hunk #19 FAILED at 7991.
> Hunk #20 FAILED at 8029.
> Hunk #21 FAILED at 8077.
> Hunk #22 FAILED at 8096.
> 21 out of 22 hunks FAILED — saving rejects to file q931.c.rej
>
> What this mean? The installation libpri-1.4.11.5 already contains the libpri-1.4.11.5-patch and the install libpri-1.4.11.5 already newer than the libpri-1.4.11.5-patch? So it failed to apply the changes to the q931 file?
>
> As I see that I am facing a problem with applying the patch to the q931 while at the same time the D-channel is related to the q931, so it could seriously a bug?
>
> I am now confused, not able to know if the installation newer than the patch or I am missing something in doing the patch?
>
> In case the installation newer than the patch, so I will resolve my problem? Shall I come back for previous version or I have to go for beta version 🙁 !!
>
> Please help.
>
> Regards
> Bilal
>
> —————-
>
>>
>> http://www.linuxtutorialblog.com/post/introduction-using-diff-and-patch-tutorial
>>
>> > —–Original Message—–
>> > From: asterisk-users-bounces@lists.digium.com
>> > [mailto:asterisk-users-bounces@lists.digium.com]
>> On Behalf Of
>> > bilal ghayyad
>> > Sent: Tuesday, June 14, 2011 2:47 PM
>> > To: asterisk-users@lists.digium.com
>> > Subject: Re: [asterisk-users] sig_pri.c:985
>> pri_find_dchan:
>> > Span 1: D-chanannel anyway!
>> >
>> > Dears;
>> >
>> > To patch libpri: I just place the patch file in the
>> libpri
>> > source directory and then I run make and make
>> install?
>> >
>> > Or I need to compile the dahdi and asterisk also?
>> >
>> > If the problem stayed, do I have to go for previous
>> libpri
>> > version? Or for previous dahdi version and asterisk
>> version?
>> >
>> > Regards
>> > Bilal
>> >
>> > ———–
>> >
>> > > bilal ghayyad wrote:
>> > > > But I am afraid it is a bug because I read
>> something
>> > > this in the below
>> > >
>> > > This bug is referring to Zaptel, not dahdi.
>> > >
>> > > If things were working fine, and you haven’t made
>> any
>> > > recent changes, in
>> > > my experience it’s always been provider (99%) or
>> cable (1%)
>> > > issues when
>> > > I’ve lost my D channel.
>> > >
>> > > Doug
>> > >
>> > > —
>> > >
>> > >
>> > > You know I’m a flight engineer but non of the
>> airlines
>> > > wanted to hire
>> > > me because other than the self proclaimed title I
>> have no
>> > > clue how to
>> > > operate or maintain an aircraft.
>> > > The dictionary is probably wrong you should patch
>> libpri
>> > >
>> > > On Tue, Jun 14, 2011 at 11:43 AM, bilal ghayyad
>> >

>> > > wrote:
>> > > > The provider came to the site and they have
>> a gateway,
>> > > they connected the gateway to the E1 cable, and
>> we called
>> > > the number and it answered !!!
>> > > >
>> > > > So it is no more provider issue.
>> > > >
>> > > > I start beleive, it is a bug maybe in the
>> dahdi and
>> > > libpri. I tried all the possibilities, but no
>> luck.
>> > > >
>> > > > WHAT COULD BE?
>> > > >
>> > > >
>> > > > Regards
>> > > > Bilal
>> > > > ——————
>> >
>
>
> —
> _____________________________________________________________________
> — Bandwidth and Colocation Provided by http://www.api-digital.com
> New to Asterisk? Join us for a live introductory webinar every Thurs:
>               http://www.asterisk.org/hello
>
> asterisk-users mailing list
> To UNSUBSCRIBE or update options visit:
>   http://lists.digium.com/mailman/listinfo/asterisk-users
>