Using Asterisk/Digium repos => Astribank firmware not found

Home » Asterisk Users » Using Asterisk/Digium repos => Astribank firmware not found
Asterisk Users No Comments

Hello,

I’m writing here hoping to have a hint from Asterisk/Digium packager
maintainer, Jason Parker (of course that any other’s opinion is
welcomed).

We have installed an asterisk machine using Asterisk and Digium repos.
Unfortunately we have found that an Astribank could not be connected
due to the lack of the firmware files

May 18 14:19:22 tenora1 kernel: usb 1-6: new high speed USB device
using ehci_hcd and address 3
May 18 14:19:22 tenora1 kernel: usb 1-6: configuration #1 chosen from 1 choice
May 18 14:19:22 tenora1 ‘xpp_fxloader'[15168]: Trying to find what to
do for product e4e4/1160/101, device /dev/bus/usb/001/003
May 18 14:19:22 tenora1 ‘xpp_fxloader'[15172]: Loading firmware
‘/usr/share/dahdi/USB_FW.hex’ into ‘/dev/bus/usb/001/003’
May 18 14:19:22 tenora1 ‘xpp_fxloader'[15174]:
/usr/share/dahdi/USB_FW.hex: unable to open for input.
May 18 14:19:22 tenora1 ‘xpp_fxloader'[15175]: fxload failed with status 254

It was not supposed to have the firmware files into one of the dahdi RPMs?

If not – from where could we download them (as I understand there are
several ones)?

Please find below some information regarding our machine.

Best regards,
Ioan.

===
[tenora1 ~]# rpm -qa | grep dahdi | sort
asterisk14-dahdi-1.4.40.1-1_centos5
dahdi-firmware-2.0.2-1_centos5
dahdi-firmware-hx8-2.06-1_centos5
dahdi-firmware-oct6114-064-1.05.01-1_centos5
dahdi-firmware-oct6114-128-1.05.01-1_centos5
dahdi-firmware-tc400m-MR6.12-1_centos5
dahdi-linux-2.4.1.2-1_centos5
dahdi-tools-2.4.0-2_centos5
kmod-dahdi-linux-2.4.1.2-1_centos5.2.6.18_238.9.1.el5
kmod-dahdi-linux-fwload-vpmadt032-2.4.1.2-1_centos5.2.6.18_238.9.1.el5

[tenora1 ~]# ls -rtl /usr/share/dahdi/
total 20
-rwxr-xr-x 1 root root 8406 Nov 23 23:49 xpp_fxloader
-rwxr-xr-x 1 root root 2415 Nov 23 23:49 waitfor_xpds
-rwxr-xr-x 1 root root 2881 Nov 23 23:49 astribank_hook

[tenora1 tmp]# rpm -qf /usr/share/dahdi/xpp_fxloader
dahdi-tools-2.4.0-2_centos5
===