Unable to REGISTER to the Asterisk v1.8.3.3 server via SIP/TLS

Home » Asterisk Users » Unable to REGISTER to the Asterisk v1.8.3.3 server via SIP/TLS
Asterisk Users 5 Comments

Hello all,

I have installed the .deb packages of the Asterisk v1.8.3.3 from the
upstream project on my Debian GNU/Linux Squeeze server and bought the
Comodo’s PossitiveSSL SSL certificate to be used for my SIP/TLS
exercise. After setting up everything and trying to fix this problem,
I am still getting a 401 Unauthorized SIP message. So as of this
writing, I still cannot successfully REGISTER to my Asterisk box.

Below are the snippets of my Asterisk and SNOM 300 configurations
including the logs for your reference.

I hope anyone from this community can help me solve this problem. A
HOWTO of a similar scenario will help a lot.

Thank you in advance.

Regards,

GNUbie

– – – ASTERISK v1.8.3.3 – – –

[ /etc/asterisk/sip.conf ]

[general]


tlsenable=yes
tlsbindaddr=0.0.0.0
tlscertfile=/etc/asterisk/keys/pbx.domain.com.pem
tlscipher=ALL
tlsclientmethod=tlsv1
tlsbindport=5061
externtlsport=5061
externtcpport=5061
tcpbindaddr=0.0.0.0
tcpbindport=5061
tcpenable=yes
srvlookup=yes

[361]
username=361
secret=*******
callerid=”361-tls”<361>
mailbox=361@family
context=family
transport=tls
port=5061
type=friend
host=dynamic
dtmfmode=rfc2833
canreinvite=no
nat=yes
qualify=yes
autoframing=yes
encryption=yes

*CLI> core show version
Asterisk 1.8.3.3-1digium1~squeeze built by pbuilder @ nighthawk on a
x86_64 running Linux on 2011-04-22 17:50:44 UTC

*CLI> sip show settings

Global Settings:

5 thoughts on - Unable to REGISTER to the Asterisk v1.8.3.3 server via SIP/TLS