Setting up 1.6.2.9 on Debian 6.0 Squeeze

Home » Asterisk Users » Setting up 1.6.2.9 on Debian 6.0 Squeeze
Asterisk Users No Comments

Hello.

I would need some help trying to setup Asterisk 1.6.2.9-2+squeeze1
on a Debian 6.0 system. I’d like to use the Debian packages, hence
the “strange” version number…

Since I’m new to Asterisk, I’m trying to follow “The Asterisk Book”
at http://www.the-asterisk-book.com/unstable/minimale-telefonanlage.html
and created a VERY basic sip.conf; see http://min.us/my-asterisk#2 or
http://min.us/my-asterisk#1 for the complete /etc/asterisk directory.

[general]
udpbindaddr=0.0.0.0
tcpenable=yes
tcpbindaddr=0.0.0.0
srvlookup=yes
realm=tel.skwar.me

[2000]
type=friend
secret=1234
host=dynamic

[2002]
type=friend
secret=0220
host=dynamic
; EOF

Now I’m trying to connect to my Asterisk using the Siphon SIP
softphone on iPhone; I’ve set username to 2000, password to
1234 and hostname to tel.skwar.me. See the following screenshots:

http://min.us/ljUzFG
http://min.us/ljQhr8
http://min.us/ljU6ee
http://min.us/ljQjzG

But it just doesn’t “register”… 🙁
When I do a “sip set debug on”, I see some output on the console,
see http://min.us/my-asterisk#3

I am trying to connect to my Asterisk server over UMTS; my
provider, Swisscom in Switzerland, says, that they do NOT block
port 5060 and/or SIP in general. This seems to be true, since
I can connect just fine using this iPhone App to the pbxes.org
Asterisk server and also other SIP servers that I tried. Interestingly,
when I enter the account details of my (non-working?) Asterisk
server in pbxes.org, it can connect to/register with my server
just fine; pbxes.org is also running Asterisk. I also had some other
guy from IRC trying to register with his Asterisk to my system
and this worked. This shows (I think…), that it should work in
general.

Well. I’m lost… Could somebody *please* try to help me? I cannot
figure it out…

Thanks a lot,

Alexander