Asterisk 1.4.38 – unknown signalling bri_cpe

Home » Asterisk Users » Asterisk 1.4.38 – unknown signalling bri_cpe
Asterisk Users 8 Comments

Hi,

we upgraded an Asterisk 1.4 with mISDN to 1.6 with chan_dahdi. Due to
problems with iax channel posted earlier, we wanted to switch back to
1.4 version.

Server has 2 HBA cards, everything is running fine with 1.6, bri_cpe is
recognized and the 7 euroISDN channels are running well, ingoing and
outgoing.

Now we installed 1.4.38 version and no more ISDN. In logs we found this:

[2010-12-24 14:50:38] VERBOSE[1773] logger.c: == Parsing
‘/etc/asterisk/chan_dahdi.conf’: [2010-12-24 14:50:38] VERBOSE[1773]
logger.c: Found
[2010-12-24 14:50:38] ERROR[1773] chan_dahdi.c: Unknown signalling
method ‘bri_cpe’

[2010-12-24 14:50:38] ERROR[1773] chan_dahdi.c: Signalling must be
specified before any channels are.

We think about a bug in libpri 1.4.11.4 so installed 1.4.11.5, same
result. Dahdi linux and tools are 2.4.0 And yes, Asterisk is build with
libpri 😉

dh@myPhoneServer:/usr/src$ strings
/usr/src/asterisk-1.4.38/channels/chan_dahdi.so | grep ‘^DAHDI Telephony’
DAHDI Telephony w/PRI
DAHDI Telephony Driver w/PRI

Thanks for your help

8 thoughts on - Asterisk 1.4.38 – unknown signalling bri_cpe

  • Le 27/12/2010 20:09, Kevin P. Fleming a écrit :

    Ouch 🙁 Are Digiums HB8 cards working with mISDN and Asterisk 1.4?

  • Not to my knowledge; Digium has not produced an mISDN driver for the HX
    series cards, and I doubt anyone else has.

  • Le 28/12/2010 13:10, Kevin P. Fleming a écrit :

    You should modify your ADL_quickstart document on Digium store to
    precise the Asterisk version compatible with those cards (perhaps also
    in datasheet or somewhere else). At this time you have
    Asterisk-X.X-current.tar.gz but as 1.4, 1.6.2 and 1.8 are existing in
    current, I will not be the only one making this mistake.

  • The Hx8 card manual (on the Digium website) clearly states on page 46
    that the minimum required version of Asterisk for use with these cards
    is Asterisk 1.6.0.1. It is possible to use Asterisk 1.4.x with these
    cards, but only with analog (FXO and FXS) modules, not BRI modules. This
    is repeated on page 49, where the manual says to download “the latest
    release version of Asterisk 1.6 or later”.

    The ADL_quickstart document you are referring to is generic and does not
    take into account the specific requirements of particular card models
    and/or configurations; users need to refer to the manuals for the cards
    and modules they plan to use to get a complete understanding of the
    required software components and their versions.

  • HI

     

    We are trying to setup Trixbox for Multiple tenant so please
    guide us.

     

    We are using TrixBox 2.6 CE

    Thanks
    Amardeep

  • If you have a suggestion for a better place for this information to be
    made available, please let us know. Our resellers are supposed to know
    these things as well, which is the best method of ensuring that
    customers in each country around the world are kept informed.

    In the meantime I’ll suggest that the web site team update the Hx8
    product page on the website to include a statement about Asterisk 1.4.x
    not supporting BRI modules on these cards.

    Glad to hear it; hopefully that will take care of your issues.

  • Le 28/12/2010 20:31, Kevin P. Fleming a écrit :
    For instance in overview of Hx8:

    “New with the release of the H8 cards is Digium’s B400M four-port
    EuroISDN S/T module. The B400M sets a new standard for BRI connectivity
    in the Asterisk market with its support for software-selectable mode (NT
    or TE) and line termination. The B400M requires no jumpers for
    operation, regardless of mode or termination. This module is compatible
    with Asterisk starting from 1.6 version and above”