Call rejected, CallToken Support required

Home » Asterisk Users » Call rejected, CallToken Support required
Asterisk Users No Comments

I had two asterisk servers connected with each other, both were 1.4.22
but I’ve upgraded one to 1.4.37 and now I get a message when I try call from asterisk-1.4.22 to asterisk-1.4.37

ERROR[4539]: chan_iax2.c:4330 handle_call_token: Call rejected,
CallToken Support required. If unexpected, resolve by placing address
192.168.140.1 in the calltokenoptional list or setting user guest
requirecalltoken=no

on asterisk-1.4.37 I have in iax.conf (requirecalltoken=no)

[clinic_server]
type=friend
host=dynamic
context=internal
disallow=all
allow=ulaw
allow=alaw
allow=g729
requirecalltoken=no

and I can call to asterisk-1.4.22 but asterisk-1.4.22 can not connect to 1.4.37 (as error listed above)

Are those two asterisks compatible?
I’ve tried placing “requirecalltoken=no” in iax.conf on asterisk-1.4.22 but it is not working.

Any suggestion.