Asterisk 1.6 (Web-meetme)

Home » Asterisk Users » Asterisk 1.6 (Web-meetme)
Asterisk Users 5 Comments

Hi,

I am really not sure if this is related to the meetme in asterisk OR
this is something to do in web-meetme. I tried to google but didnt get
any proper results.
I am facing one issue in Web-meetme on the expiry of any conference
that we create.
I am having Web-meetme 4.0.2 over Asterisk 1.6
Any conference we create in web-meetme never expires. I am not sure if
i am missing while configuring, though i didnt find anything in
lib/define.php also checked in asterisk that can point me, which can
help me in fixing this issue.

Can someone please help me in fixing this.

5 thoughts on - Asterisk 1.6 (Web-meetme)

  • Manmohan wrote:

    Since you can join the conference you created with WMM, the Realtime
    settings are likely correct.

    You do not mention which version of 1.6 you are on, so I would guess
    that you are on 1.6.2.7 or older. For a variety of reasons the
    realtime feature, in particular the scheduling code, was added and
    tweaked over a wide range of 1.6 releases. The first one I would consider
    feature complete for use with Web-MeetMe is 1.6.2.7, and even that version
    has a trivial, but nasty bug that causes segfaults (fixed in a recent 1.6.2
    release)

    Dan

  • Manmohan wrote:
    Do you have schedule=yes in meetme.conf? I incorrectly
    remembered/thought that all of the Realtime features were
    controlled by that option, only a small number, such as
    end times and CDR logging

  • Hi Dan,

    In meetme.conf the schedule=yes was commented, after removing its working fine.

    But one strange thing had started now. I started getting segmentation fault.

    following are the errors which i see in it:

    warning: difference appears to be caused by prelink, adjusting expectations

    warning: .dynamic section for “/usr/lib/libodbcinst.so.1” is not at
    the expected address

    warning: difference appears to be caused by prelink, adjusting expectations

    warning: .dynamic section for “/usr/lib/libogg.so.0” is not at the
    expected address

    warning: difference appears to be caused by prelink, adjusting expectations

    warning: .dynamic section for “/usr/lib/libbluetooth.so.2” is not at
    the expected address

    warning: difference appears to be caused by prelink, adjusting expectations
    Reading symbols from /lib/libssl.so.6…(no debugging symbols found)…done.
    Loaded symbols for /lib/libssl.so.6
    Reading symbols from /lib/libcrypto.so.6…(no debugging symbols found)…done.
    Loaded symbols for /lib/libcrypto.so.6
    Reading symbols from /lib/libc.so.6…(no debugging symbols found)…done.
    Loaded symbols for /lib/libc.so.6
    Reading symbols from /usr/lib/libxml2.so.2…(no debugging symbols
    found)…done.
    Loaded symbols for /usr/lib/libxml2.so.2
    Reading symbols from /usr/lib/libz.so.1…(no debugging symbols found)…done.
    Loaded symbols for /usr/lib/libz.so.1

    Thanks & Regards
    Manmohan Singh

  • The errors you posted do not point to a the problem.

    Did you build from source or are you using packages?

    If from source, grep for useropts in app_meetme.c and
    The second instance should be:

    char useropts[OPTIONS_LEN + 1] = “”;

    If the line does not have the = “”, then the issue is that
    the bug I mentioned is still present.