Dahdi 2.4.0 and unplugged spans

Home » Asterisk Users » Dahdi 2.4.0 and unplugged spans
Asterisk Users 2 Comments

Hi,

I’m facing an issue with which loading wctdm24xxp module fails.

Here is relevant dmesg’s output :

[ 13.455729] dahdi: Telephony Interface Registered on major 196
[ 13.455729] dahdi: Version: 2.4.0
[ 13.510847] ACPI: PCI Interrupt 0000:01:0b.0[A] -> GSI 22 (level, low) ->
IRQ 22
[ 15.527788] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 17.527787] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 19.527787] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 21.527785] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 23.527784] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 25.527785] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 27.527785] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 29.527785] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 31.527785] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 33.527942] wctdm24xxp 0000:01:0b.0: Timeout waiting for receive frame.
[ 33.527995] wctdm24xxp 0000:01:0b.0: The firmware may be corrupted.
Please completely power off your system, power on, and then reload th
e driver with the ‘forceload’ module parameter set to 1 to attempt recovery.
[ 33.544741] ACPI: PCI interrupt for device 0000:01:0b.0 disabled
[ 33.544757] wctdm24xxp: probe of 0000:01:0b.0 failed with error -5
[ 34.157817] dahdi: Registered tone zone 2 (France)
[ 38.873158] warning: `ntpd’ uses 32-bit capabilities (legacy support in
use)
[ 47.462040] dahdi: Detected time shift.

My setup is :
Asterisk box with HA8+B400M <---ISDN/BRI----> Patton SN4638 <----SIP--->
Asterisk

Patton SN4638 is configured to behave as telco node (ie NT/PtmP).

To narrow my research scope, I’m wondering if the followin sentence is true
:
“if you load a dahdi module with a modprobe command (like modprobe
wctdm24xxp) disconnect any cable of any kind connected to the corresponding
PCI board, should this command succeed or fail”

In other words, do you need to connect board to a public network when
configuring it ?

Regards

2 thoughts on - Dahdi 2.4.0 and unplugged spans

  • The essential thing here is that your Hx8 board doesn’t appear to be
    responding. I’ve seen certain systems where revision 9397 [1] works
    around cases like what you’re seeing. If that doesn’t help your best
    bet is to contact Digium technical support for help with troubleshooting.

    [1] http://svn.asterisk.org/view/dahdi?view=revision&revision=9397

    No, the current alarm state of any ports doesn’t matter when you
    configure the board. The configuration of modules on a given Hx8
    basecard will not affect whether the driver is able to load or not.

    Cheers,
    Shaun