DAHDI 2.4.0 produces HDLC errors with echo canceler

Home » Asterisk Users » DAHDI 2.4.0 produces HDLC errors with echo canceler
Asterisk Users 2 Comments

Hi,
After upgrading to DAHDI 2.4.0 from Zaptel, I noticed a lot of HDLC
errors on my console:
[Nov 27 01:15:09] NOTICE[2743] chan_dahdi.c: PRI got event: HDLC Bad
FCS (8) on Primary D-channel of span 1
[Nov 27 01:15:09] NOTICE[2743] chan_dahdi.c: PRI got event: HDLC Abort
(6) on Primary D-channel of span 1

These errors prevented calls from being made and received on my PRI spans.

This seems similar to bug 15498:
https://issues.asterisk.org/view.php?id=15498
Which says this was fixed in 2.2…so maybe it got back into 2.4?

I can get rid of the errors by disabling the mg2 echo canceler in
/etc/dadhi/system.conf.

The PRI card I’m using is a Digium TE122.
I’d prefer not having to run with the echo canceler off of course…

[1]
active=yes
alarms=OK
description=Wildcard TE122 Card 0
name=WCT1/0
manufacturer=Digium
devicetype=Wildcard TE122
location=PCI Bus 03 Slot 03
basechan=1
totchans=24
irq=35
type=digital-T1
syncsrc=1
lbo=0 db (CSU)/0-133 feet (DSX-1)
coding_opts=B8ZS,AMI
framing_opts=ESF,D4
coding=B8ZS
framing=ESF

Thanks.

2 thoughts on - DAHDI 2.4.0 produces HDLC errors with echo canceler

  • Do you have a hardware echocan module installed on your card? If so,
    it’s strange indeed that the error goes away when you disable mg2.

    What is the complete output of your /etc/dahdi/system.conf?

  • Nope,
    No h/w echo canceler on this card.
    Here’s system.conf:

    span=1,1,0,esf,b8zs
    # termtype: te
    bchan=1-23
    dchan=24

    # Global data

    loadzone = us
    defaultzone = us