* You are viewing the archive for November 25th, 2010

d-link dvg-3032 guidance

Hi all,
Anyboby has some experience with D-link dvg-3032s with asterisk and could give me some support.
I am using this dial plan :
exten => _X. ,1,Dial(SIP/${EXTEN:0}@192.168.0.60,30)But I receive the mesagem from C.O that the number is incorrect.
And about incoming calls, I put I asterisk extension on FXO Hot-line, the call is shown on status of the dvg-3032 but nothing is shown on asterisk CLI.
Thanks for any help.

Att,

Flavio Roberto Miranda

MSN:flaviormiranda@hotmail.com
Skype: flaviormiranda

IAX inbound failing

Hi,

I’m testing an upgrade from 1.4.18 to 1.4.37 in a VM prior to putting it
into production.

Ive done this by installing 1.4.18 onto the VM, putting my config files
in place and then installing 1.4.37 over the top (which is what I’d have
to do on production).

I’ve found a few issues in the config files, but nothing I couldn’t
handle until… I hit inbound IAX issues.

My Voip provider has already told me that they don’t use tokens, so I’ve
added requirecalltoken=no into iax.conf

However when a call is placed and routed to the VM, nothing appears in
the CLI to show the call coming in.

If I turn on IAX debug, I can see an initial message, and if I take that
requirecalltoken line out and remake the call, then I get an error from
Asterisk telling me that I need the line in to process the call – so the
call is getting to Asterisk (not a firewall issue then).

The call logic was working fine prior to the upgrade, and as I don’t get
one line of output at the CLI I’m wondering what is going on!

I can see the INVAL in the debug, but I’m not sure what that’s actually
meaning – is it authentication?? The username/secret are all valid.

My iax.conf entry looks like:

[inboundcontext]

type=user

context=incomming_pstn

username=inboundcontext

secret=xxxxxx

host=dynamic

trunk=yes

requirecalltoken=no

Any ideas ?

Thanks,

Adrian

IAX Trace:

Rx-Frame Retry[ No] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
NEW

Timestamp: 00007ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

VERSION : 2

CALLED NUMBER : 2095

CODEC_PREFS : ()

CALLING NUMBER : 01793xxxxxx

CALLING PRESNTN : 0

CALLING TYPEOFN : 0

CALLING TRANSIT : 0

CALLING NAME :

LANGUAGE : en

USERNAME : inboundcontext

FORMAT : 8

CAPABILITY : 65407

ADSICPE : 2

DATE TIME : 2010-11-25 17:01:46

Tx-Frame Retry[000] — OSeqno: 000 ISeqno: 001 Type: IAX Subclass:
AUTHREQ

Timestamp: 00011ms SCall: 00403 DCall: 00006 [212.11.91.201:4569]

AUTHMETHODS : 3

CHALLENGE : 167512360

USERNAME : inboundcontext

Rx-Frame Retry[ No] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
INVAL

Timestamp: 00000ms SCall: 00006 DCall: 00403 [212.11.91.201:4569]

Rx-Frame Retry[Yes] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
NEW

Timestamp: 00007ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

VERSION : 2

CALLED NUMBER : 2095

CODEC_PREFS : ()

CALLING NUMBER : 01793xxxxxx

CALLING PRESNTN : 0

CALLING TYPEOFN : 0

CALLING TRANSIT : 0

CALLING NAME :

LANGUAGE : en

USERNAME : inboundcontext

FORMAT : 8

CAPABILITY : 65407

ADSICPE : 2

DATE TIME : 2010-11-25 17:01:46

Tx-Frame Retry[000] — OSeqno: 000 ISeqno: 001 Type: IAX Subclass:
AUTHREQ

Timestamp: 00007ms SCall: 09750 DCall: 00006 [212.11.91.201:4569]

AUTHMETHODS : 3

CHALLENGE : 151094941

USERNAME : inboundcontext

Rx-Frame Retry[ No] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
INVAL

Timestamp: 00000ms SCall: 00006 DCall: 09750 [212.11.91.201:4569]

Rx-Frame Retry[ No] — OSeqno: 001 ISeqno: 000 Type: IAX Subclass:
LAGRQ

Timestamp: 09835ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

Rx-Frame Retry[Yes] — OSeqno: 001 ISeqno: 000 Type: IAX Subclass:
LAGRQ

Timestamp: 09835ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

Rx-Frame Retry[Yes] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
NEW

Timestamp: 00007ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

VERSION : 2

CALLED NUMBER : 2095

CODEC_PREFS : ()

CALLING NUMBER : 01793xxxxxx

CALLING PRESNTN : 0

CALLING TYPEOFN : 0

CALLING TRANSIT : 0

CALLING NAME :

LANGUAGE : en

USERNAME : inboundcontext

FORMAT : 8

CAPABILITY : 65407

ADSICPE : 2

DATE TIME : 2010-11-25 17:01:46

Tx-Frame Retry[000] — OSeqno: 000 ISeqno: 001 Type: IAX Subclass:
AUTHREQ

Timestamp: 00015ms SCall: 10434 DCall: 00006 [212.11.91.201:4569]

AUTHMETHODS : 3

CHALLENGE : 102034710

USERNAME : inboundcontext

Tx-Frame Retry[000] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
POKE

Timestamp: 00017ms SCall: 02331 DCall: 00000 [82.71.203.26:4569]

Rx-Frame Retry[ No] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
INVAL

Timestamp: 00000ms SCall: 00006 DCall: 10434 [212.11.91.201:4569]

Tx-Frame Retry[001] — OSeqno: 000 ISeqno: 000 Type: IAX Subclass:
POKE

Timestamp: 00017ms SCall: 02331 DCall: 00000 [82.71.203.26:4569]

Rx-Frame Retry[ No] — OSeqno: 002 ISeqno: 000 Type: IAX Subclass:
LAGRQ

Timestamp: 19834ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

Rx-Frame Retry[ No] — OSeqno: 003 ISeqno: 000 Type: IAX Subclass:
HANGUP

Timestamp: 19945ms SCall: 00006 DCall: 00000 [212.11.91.201:4569]

Unit of measurement dahdi_monitor

I am studying about echo cancellation in asterisk and I want to use the
numeric information from dahdi_monitor verbose for my research.
Unfortunately, I couldn’t find anything about the unit of measurement used
in this tool. Which unit is used to measure the signal level?

Timing cable usage necessity

Hello everyone.

I have a timing slips errors and I can’t understand what source of the
problem is.
My installation has 2 digium cards: TE420 and TE220 cards in one server.
There are 3 spans (E1) to PSTN and 3 spans to internal PBS stations -
normal installation for transit communication.
Span configuration is:
span=1,1,0,ccs,hdb3 #TE420 – first port. To PSTN.
span=2,0,0,ccs,hdb3 #TE420 – second port. To PBX.
span=3,2,0,ccs,hdb3 #TE420 – third port. To PSTN.
span=4,0,0,ccs,hdb3 #TE420 – fourth port. To PBX.
span=5,3,0,ccs,hdb3 #TE220 – first port. To PSTN.
span=6,0,0,ccs,hdb3 #TE220 – second port. To PBX.
I should to say, that PBXs are interconnected through router (doesn’t
know anything about it). So all schema looks like this:
http://yfrog.com/jjschemaj
Spans 1-5 works fine, but on span 6 (marked bold) I have rising timing
slips counter.

I think it’s appearing because I’m getting a primary timing source on
span 1 – first port on TE420. But TE220 doesn’t use it’s span 5 for
timing source, because it has priority 3, so it could be a sync problem.
Am I wrong?

I’m started to think about timing cable for syncing timing on first card
and second. Should I use it?

It’s a problem to bought cable in our city (Russia,Moscow). All
resellers sell only cards. Could I use floppy or IDE cable to
interconnect cards? As I see in picture of cable, it’s a direct 16 pin
cable.

Does anybody know something about timing cable for different cards? How
I can solve my problem?
Thanks for attention

Avoided deadlock Error(solved)

The proble is dialplan I configure fine

Siemens HiPath 1120

Hi all,

I want to use asteriks with my siemens hipath 1120 hardware.
Is it possible?

Thanks